package/qt5/qt5wayland: install compositor QML files
authorDavid Rosca <nowrep@gmail.com>
Tue, 14 May 2019 07:18:29 +0000 (09:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 May 2019 20:03:15 +0000 (22:03 +0200)
Fixes using QtWayland.Compositor QML import.

Signed-off-by: David Rosca <nowrep@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qt5/qt5wayland/qt5wayland.mk

index f96e4c2f8f7ae70e529bf6664f7b776e35a08ae7..449640c88149820b13855a7ebfd2b1b60d9be5e1 100644 (file)
@@ -52,6 +52,11 @@ define QT5WAYLAND_INSTALL_COMPOSITOR
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Compositor.so* $(TARGET_DIR)/usr/lib
 endef
 endif
+ifeq ($(BR2_PACKAGE_QT5DECLARATIVE_QUICK),y)
+define QT5WAYLAND_INSTALL_COMPOSITOR_QMLS
+       cp -dpfr $(STAGING_DIR)/usr/qml/QtWayland $(TARGET_DIR)/usr/qml/
+endef
+endif
 endif
 
 ifeq ($(BR2_PACKAGE_QT5BASE_EXAMPLES),y)
@@ -65,6 +70,7 @@ define QT5WAYLAND_INSTALL_TARGET_CMDS
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/plugins/wayland* $(TARGET_DIR)/usr/lib/qt/plugins
        cp -dpfr $(STAGING_DIR)/usr/lib/qt/plugins/platforms/libqwayland* $(TARGET_DIR)/usr/lib/qt/plugins/platforms
        $(QT5WAYLAND_INSTALL_COMPOSITOR)
+       $(QT5WAYLAND_INSTALL_COMPOSITOR_QMLS)
        $(QT5WAYLAND_INSTALL_TARGET_EXAMPLES)
 endef