projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
721e4cb
)
botan: fix build on arm without neon
author
Fabrice Fontaine
<fontaine.fabrice@gmail.com>
Fri, 7 Sep 2018 19:17:36 +0000
(21:17 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Sat, 8 Sep 2018 12:47:59 +0000
(14:47 +0200)
configure.py only supports --disable-neon
Fixes:
- http://autobuild.buildroot.org/results/
26eec7e20795068613616a7312681853232ec764
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk
patch
|
blob
|
history
diff --git
a/package/botan/botan.mk
b/package/botan/botan.mk
index 39a2c4c72b5132ebc663134122e87e83de5b3aab..e352fab6c94c4780d04d28bb9714f16bed4ff52b 100644
(file)
--- a/
package/botan/botan.mk
+++ b/
package/botan/botan.mk
@@
-74,6
+74,10
@@
ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),)
BOTAN_CONF_OPTS += --disable-altivec
endif
+ifeq ($(BR2_ARM_CPU_HAS_NEON),)
+BOTAN_CONF_OPTS += --disable-neon
+endif
+
define BOTAN_CONFIGURE_CMDS
(cd $(@D); $(TARGET_MAKE_ENV) ./configure.py $(BOTAN_CONF_OPTS))
endef