package/nbd: fix utilities locations
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 12 Mar 2017 09:58:16 +0000 (10:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Mar 2017 13:27:34 +0000 (14:27 +0100)
Currently, the code expects both the client and server to be in
/usr/bin, while the client is in /usr/sbin

Fix that.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nbd/nbd.mk

index c7c327eb3843bc94e7cb97e58d411dc92b8f9f11..92660c2f1144b1456a9b7b2186455e954a513468 100644 (file)
@@ -19,14 +19,14 @@ NBD_CONF_ENV = ac_cv_header_linux_falloc_h=no
 endif
 
 ifneq ($(BR2_PACKAGE_NBD_CLIENT),y)
-NBD_TOREMOVE += nbd-client
+NBD_TOREMOVE += /usr/sbin/nbd-client
 endif
 ifneq ($(BR2_PACKAGE_NBD_SERVER),y)
-NBD_TOREMOVE += nbd-server
+NBD_TOREMOVE += /usr/bin/nbd-server
 endif
 
 define NBD_CLEANUP_AFTER_INSTALL
-       rm -f $(addprefix $(TARGET_DIR)/usr/sbin/, $(NBD_TOREMOVE))
+       rm -f $(addprefix $(TARGET_DIR), $(NBD_TOREMOVE))
 endef
 
 NBD_POST_INSTALL_TARGET_HOOKS += NBD_CLEANUP_AFTER_INSTALL