boost: fix build with ccache
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 16:58:22 +0000 (17:58 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Jan 2012 16:58:22 +0000 (17:58 +0100)
Drop quotes around TARGET_CXX as the boost buildsystem does handle
spaces in the compiler command name, but treats it as a single command
(and errors out) if quotes are used and ccache enabled.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/boost/boost.mk

index 4bbc869045d1c713fdb3040f829ac051822f344a..4577f2dcc0b33885c870352d620697f249e1aa17 100644 (file)
@@ -52,7 +52,7 @@ BOOST_FLAGS += $(if $(BOOST_WITHOUT_FLAGS_COMMASEPERATED), --without-libraries=$
 
 define BOOST_CONFIGURE_CMDS
        (cd $(@D) && ./bootstrap.sh $(BOOST_FLAGS))
-       echo "using gcc : $(TARGET_CC_VERSION) : \"$(TARGET_CXX)\" : <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > $(@D)/user-config.jam
+       echo "using gcc : $(TARGET_CC_VERSION) : $(TARGET_CXX) : <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > $(@D)/user-config.jam
        echo "" >> $(@D)/user-config.jam
 endef