package/proftpd: add ftpasswd
authorJared Bents <jared.bents@rockwellcollins.com>
Fri, 28 Sep 2018 17:57:39 +0000 (12:57 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 15:21:40 +0000 (17:21 +0200)
- Copies over ftpasswd if perl is enabled

Signed-off-by: Paresh Chaudhary <paresh.chaudhary@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Jared Bents <jared.bents@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/proftpd/proftpd.mk

index 93ee687fab9f692b6dd08ddeea0501e6d26bd6f9..8f3ff5088e4c0319e44cd319e105173d143f4407 100644 (file)
@@ -93,12 +93,16 @@ define PROFTPD_INSTALL_FTPQUOTA
        $(INSTALL) -D -m 0755 $(@D)/contrib/ftpquota $(TARGET_DIR)/usr/sbin/ftpquota
 endef
 endif
+define PROFTPD_INSTALL_FTPASSWD
+       $(INSTALL) -D -m 0755 $(@D)/contrib/ftpasswd $(TARGET_DIR)/usr/sbin/ftpasswd
+endef
 endif
 
 define PROFTPD_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0755 $(@D)/proftpd $(TARGET_DIR)/usr/sbin/proftpd
        $(INSTALL) -m 0644 -D $(@D)/sample-configurations/basic.conf $(TARGET_DIR)/etc/proftpd.conf
        $(PROFTPD_INSTALL_FTPQUOTA)
+       $(PROFTPD_INSTALL_FTPASSWD)
 endef
 
 define PROFTPD_USERS