package/msmtp: fix configure with openssl/gnutls
authorRyan Coe <bluemrp9@gmail.com>
Sat, 29 Dec 2018 01:21:34 +0000 (17:21 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 30 Dec 2018 15:29:13 +0000 (16:29 +0100)
Since the bump of msmtp from 1.6.6 to 1.8.0 in commit
b68ad1b2d0d1c290489e0b4e1afec46b8220a8b9 ("msmtp: bump to version
1.8.0"), the configure option to select the SSL/TLS implementation is
no longer --with-ssl, but --with-tls.

Signed-off-by: Ryan Coe <bluemrp9@gmail.com>
[Thomas: improve commit log]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/msmtp/msmtp.mk

index a495072abff9017a4e160538b6b8762c6ca74db1..a26de92ef92e6a3e71fed6c4fdf1a3b53529ee19 100644 (file)
@@ -41,17 +41,17 @@ MSMTP_CONF_OPTS += --without-libsecret
 endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
-MSMTP_CONF_OPTS += --with-ssl=openssl
+MSMTP_CONF_OPTS += --with-tls=openssl
 MSMTP_DEPENDENCIES += openssl
 ifeq ($(BR2_STATIC_LIBS),y)
 # openssl uses zlib, so we need to explicitly link with it when static
 MSMTP_CONF_ENV += LIBS=-lz
 endif
 else ifeq ($(BR2_PACKAGE_GNUTLS),y)
-MSMTP_CONF_OPTS += --with-ssl=gnutls
+MSMTP_CONF_OPTS += --with-tls=gnutls
 MSMTP_DEPENDENCIES += gnutls
 else
-MSMTP_CONF_OPTS += --with-ssl=no
+MSMTP_CONF_OPTS += --with-tls=no
 endif
 
 $(eval $(autotools-package))