i2c-tools: add busybox to dependencies if enabled
authorBartosz Golaszewski <bgolaszewski@baylibre.com>
Tue, 2 Aug 2016 10:27:35 +0000 (12:27 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Aug 2016 11:08:33 +0000 (13:08 +0200)
Before changing the install directory of i2c-tools to /usr/sbin/ make
sure busybox is built first (if selected) in order to ensure that the
symlinks to the busybox-provided versions are overwritten by the
i2c-tools' install commands.

Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/i2c-tools/i2c-tools.mk

index 9625acf8f08d16069d843c08e5ae79f433157610..38f84a3391c769f9a4b200477a9a876cb61cbf81 100644 (file)
@@ -17,6 +17,10 @@ ifeq ($(BR2_PACKAGE_PYTHON3),y)
 I2C_TOOLS_DEPENDENCIES += python3
 endif
 
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+I2C_TOOLS_DEPENDENCIES += busybox
+endif
+
 # Build/install steps mirror the distutil python package type in the python package
 # infrastructure
 ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)