webkitgtk: add an option to control USE_GSTREAMER_GL
authorAdrian Perez de Castro <aperez@igalia.com>
Thu, 25 Oct 2018 00:27:38 +0000 (03:27 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 31 Oct 2018 09:49:22 +0000 (10:49 +0100)
This covers the case where GL/GLES is available (so -DENABLE_OPENGL=ON
gets passed), which makes the webkitgtk build system assume GStreamer-GL
is available, while actually it is not.

Also, providing an option to manually disable usage of GStremer-GL can
help with certain target configurations in which using OpenGL for video
handling might result in incorrect rendering.

This fixes some autobuilder failures like the following:

  http://autobuild.buildroot.net/results/187796535af53ece426641ff7d88aabada281674
  http://autobuild.buildroot.net/results/00c1a8ea23a99728a4f3f4478705f2383414ae41

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/webkitgtk/Config.in
package/webkitgtk/webkitgtk.mk

index bf0a150251ccfc88057fbfb42cea874dad2d467f..f1228892afebfbe038109499a2f2ac774ec656b8 100644 (file)
@@ -105,6 +105,21 @@ config BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
          This option pulls in all of the required dependencies
          to enable multimedia (video/audio) support.
 
+if BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
+
+config BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL
+       bool "use gstreamer-gl"
+       default y
+       depends on BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
+       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
+       help
+         Use the GStreamer GL elements for handling video content.
+         This is recommended as it improves performance of video
+         playback. In some target configurations incorrect rendering
+         might be produced, and disabling this option may help.
+
+endif
+
 config BR2_PACKAGE_WEBKITGTK_WEBDRIVER
        bool "WebDriver support"
        help
index 39d681b1d40fb22d55981cd73317a3c0f0d100a5..1ba1cb532901979085ab5068735ec2ff1ef29990 100644 (file)
@@ -95,4 +95,11 @@ WEBKITGTK_CONF_OPTS += -DENABLE_WAYLAND_TARGET=ON
 endif
 endif
 
+ifeq ($(BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL),y)
+WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=ON
+WEBKITGTK_DEPENDENCIES += gst1-plugins-bad
+else
+WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
+endif
+
 $(eval $(cmake-package))