libcurl: optional verbose strings config
authorJudd Meinders <judd.meinders@rockwellcollins.com>
Tue, 31 Jan 2017 17:26:53 +0000 (11:26 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Feb 2017 21:01:50 +0000 (22:01 +0100)
This patch enables a config to set --enable-verbose during the
configuration of libcurl.  The option is triggered by setting
BR2_PACKAGE_LIBCURL_VERBOSE.

Signed-off-by: Judd Meinders <judd.meinders@rockwellcollins.com>
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libcurl/Config.in
package/libcurl/libcurl.mk

index 026ae0154b080b6453cfb1b91c0b4ff9771dadd6..fc1527f0d9251a5855ebfab9152e7c18a836299c 100644 (file)
@@ -13,4 +13,9 @@ config BR2_PACKAGE_CURL
        help
          Install curl binary as well
 
+config BR2_PACKAGE_LIBCURL_VERBOSE
+       bool "enable verbose strings"
+       help
+         Enable verbose text strings
+
 endif
index ea37309d82b01326fc8fe9af73f13d48b4004095..a9fba266272dcab9a5806ca813e1c81d7a0c0b16 100644 (file)
@@ -19,8 +19,15 @@ LIBCURL_INSTALL_STAGING = YES
 # on non-MMU platforms. Moreover, this authentication method is
 # probably almost never used. See
 # http://curl.haxx.se/docs/manpage.html#--ntlm.
-LIBCURL_CONF_OPTS = --disable-verbose --disable-manual --disable-ntlm-wb \
+LIBCURL_CONF_OPTS = --disable-manual --disable-ntlm-wb \
        --enable-hidden-symbols --with-random=/dev/urandom --disable-curldebug
+
+ifeq ($(BR2_PACKAGE_LIBCURL_VERBOSE),y)
+LIBCURL_CONF_OPTS += --enable-verbose
+else
+LIBCURL_CONF_OPTS += --disable-verbose
+endif
+
 LIBCURL_CONFIG_SCRIPTS = curl-config
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)