linux: fix the KCONFIG_GET_OPT calls to be inside a BR2_LINUX_KERNEL test
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Mar 2014 21:55:49 +0000 (22:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Mar 2014 21:55:49 +0000 (22:55 +0100)
The KCONFIG_GET_OPT calls added by
ca80782f4571f004c2b8cf2d0e60e83343beff34 ('linux: only depend on
host-lzop if needed') are made even if the kernel package is not
selected. This hangs the linux.mk parsing as they try to read from a
file that doesn't exist.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index 91a5fb8d814229bc2a08103edc2e27cb2e75c756..680279c9e689c289b54e3eb636871ceae35806f0 100644 (file)
@@ -170,7 +170,6 @@ ifeq ($(BR2_LINUX_KERNEL),y)
 ifeq ($(wildcard $(KERNEL_SOURCE_CONFIG)),)
 $(error Configuration file '$(KERNEL_SOURCE_CONFIG)' not found.)
 endif
-endif
 
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_KERNEL_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop
@@ -178,6 +177,7 @@ endif
 ifeq ($(call KCONFIG_GET_OPT,CONFIG_RD_LZO,$(KERNEL_SOURCE_CONFIG)),y)
 LINUX_DEPENDENCIES += host-lzop
 endif
+endif
 
 define LINUX_CONFIGURE_CMDS
        $(INSTALL) -m 0644 $(KERNEL_SOURCE_CONFIG) $(KERNEL_ARCH_PATH)/configs/buildroot_defconfig