package/e2fsprogs: bump version to fix regression
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 5 Sep 2021 17:34:46 +0000 (19:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 10 Sep 2021 16:22:09 +0000 (18:22 +0200)
Version 1.46.3 had a regression, which meant the file that would store
the filesystem image had to pre-exist, or mkfs.ext2 would fail to
generate the filesystem:

    mkfs.ext4: No such file or directory while trying to determine
    filesystem size

The regression was fixed upstream, and is now part of the 1.46.4
release, so bump to that release.

Fixes: #14196
Additionally, as noticed by Romain, the defaults settings for generating
"small" filesystems have changed: the inode size has been increased fom
128 to 256 bytes in 1.46.4 [0]. This causes the number of inodes to
diverge slightly from the requested number; instead of 8 more inodes,
there are now 8 fewer than requested.

Adapt our test accordingly.

[0] https://github.com/tytso/e2fsprogs/commit/a23b50cdb55cb826b8745cbc37429c93f7b60c66

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Reported-by: Kevin Tomary <kevin.tomary@hotmail.com>
Reported-by: Leon de Rooij <leon@exquisip.nl>
Reported-by: Romain Naour <romain.naour@gmail.com>
Tested-by: Michael Walle <michael@walle.cc>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/e2fsprogs/e2fsprogs.hash
package/e2fsprogs/e2fsprogs.mk
support/testing/tests/fs/test_ext.py

index 3661801199a905cbebee4a3e052d552d24c86f72..63c7c9929fe301ce4f570ca7fc78437b5ea99ccb 100644 (file)
@@ -1,5 +1,5 @@
 # From https://mirrors.edge.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v1.46.3/sha256sums.asc
-sha256  86d1580facdd49f2e0e6b027e26b1e6c48af538762dc40aeed2a87153c1f11b7  e2fsprogs-1.46.3.tar.xz
+sha256  b11042533c1b1dcf17512f0da48e05b0c573dada1dd8b762864d10f4dc399713  e2fsprogs-1.46.4.tar.xz
 # Locally calculated
 sha256  5da5ef153e559c1d990d4c3eedbedd4442db892d37eae1f35fff069de8ec9020  NOTICE
 sha256  032989b508f1a72ebee5b3417e55d06d473f9ee203e45ab11864a7e49cdec63d  lib/ss/mit-sipb-copyright.h
index 5528ecbc3427bb4d3677f0ab4fa4e77c9062af03..ca891066a25ada7a7f61ffd454bc29284831381c 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-E2FSPROGS_VERSION = 1.46.3
+E2FSPROGS_VERSION = 1.46.4
 E2FSPROGS_SOURCE = e2fsprogs-$(E2FSPROGS_VERSION).tar.xz
 E2FSPROGS_SITE = $(BR2_KERNEL_MIRROR)/linux/kernel/people/tytso/e2fsprogs/v$(E2FSPROGS_VERSION)
 E2FSPROGS_LICENSE = GPL-2.0, MIT-like with advertising clause (libss and libet)
index 2a6e0c4274d4d334c75735ccacb6bea8b11d438e..699f3ed932eba16add72cd85c7c9cb7e9114ebfd 100644 (file)
@@ -113,8 +113,8 @@ class TestExt4(infra.basetest.BRTest):
         out = dumpe2fs_run(self.builddir, "rootfs.ext4")
         self.assertEqual(dumpe2fs_getprop(out, REVISION_PROP), "1 (dynamic)")
         self.assertEqual(dumpe2fs_getprop(out, BLOCKCNT_PROP), "16384")
-        # Yes there are 8 more inodes than requested
-        self.assertEqual(dumpe2fs_getprop(out, INODECNT_PROP), "3008")
+        # Yes there are 8 fewer inodes than requested
+        self.assertEqual(dumpe2fs_getprop(out, INODECNT_PROP), "2992")
         self.assertEqual(dumpe2fs_getprop(out, RESBLKCNT_PROP), "1638")
         self.assertIn("has_journal", dumpe2fs_getprop(out, FEATURES_PROP))
         self.assertIn("extent", dumpe2fs_getprop(out, FEATURES_PROP))