package/libbsd: new package
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 9 May 2013 12:22:55 +0000 (12:22 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 May 2013 20:06:56 +0000 (22:06 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Nathan Lynch <ntl@pobox.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libbsd/Config.in [new file with mode: 0644]
package/libbsd/libbsd.mk [new file with mode: 0644]

index bbacd5c546c19b4e7aed66123a219f0280555c32..55a38b9bfe0dfd7dc65dfa7fe7ae0c0fd7d0b93a 100644 (file)
@@ -578,6 +578,7 @@ source "package/gmp/Config.in"
 source "package/gsl/Config.in"
 source "package/gtest/Config.in"
 source "package/libatomic_ops/Config.in"
+source "package/libbsd/Config.in"
 source "package/libcap/Config.in"
 source "package/libcap-ng/Config.in"
 source "package/libdaemon/Config.in"
diff --git a/package/libbsd/Config.in b/package/libbsd/Config.in
new file mode 100644 (file)
index 0000000..0ed9dac
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_LIBBSD
+       bool "libbsd"
+       help
+         This library provides useful functions commonly found on BSD
+         systems, and lacking on others like GNU systems, thus making
+         it easier to port projects with strong BSD origins, without
+         needing to embed the same code over and over again on each
+         project.
+
+         http://libbsd.freedesktop.org/
diff --git a/package/libbsd/libbsd.mk b/package/libbsd/libbsd.mk
new file mode 100644 (file)
index 0000000..3af1002
--- /dev/null
@@ -0,0 +1,21 @@
+#############################################################
+#
+# libbsd
+#
+#############################################################
+
+LIBBSD_VERSION         = 0.4.2
+LIBBSD_SOURCE          = libbsd-$(LIBBSD_VERSION).tar.gz
+LIBBSD_SITE            = http://libbsd.freedesktop.org/releases
+LIBBSD_LICENSE         = BSD-3c MIT
+LIBBSD_LICENSE_FILES   = LICENSE
+
+# man-pages are BSD-4c, so that license only matters
+# if doc is kept in the target rootfs
+ifeq ($(BR2_HAVE_DOCUMENTATION),y)
+LIBBSD_LICENSE        += (libraries), BSD-4c (documentation)
+endif
+
+LIBBSD_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))