package/libass: security bump to version 0.15
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 29 Oct 2020 13:24:29 +0000 (14:24 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Nov 2020 21:06:17 +0000 (22:06 +0100)
- harfbuzz is mandatory since
  https://github.com/libass/libass/commit/f3e2c97e1818598afb0b1c7010003ffe4823ff21
- Fix CVE-2020-26682 (In libass 0.14.0, the `ass_outline_construct`'s
  call to `outline_stroke` causes a signed integer overflow.) through
  https://github.com/libass/libass/commit/676f9dc5b52ef406c5527bdadbcb947f11392929
  which does not apply cleanly over version 0.14.
  It should be noted that version 0.15 also fixes other integer
  overflows (which have no CVE assigned)
- Update indentation in hash file (two spaces)

https://github.com/libass/libass/releases/tag/0.15.0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/harfbuzz/Config.in
package/kodi/Config.in
package/libass/Config.in
package/libass/libass.hash
package/libass/libass.mk

index a7ad74b8e26f1bfd88280c0ef6f1d2030c616bd1..305e0fda2f73ba6463c2d57c06b86c1ee5f98d40 100644 (file)
@@ -326,8 +326,16 @@ comment "plugins with external dependencies"
 
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_ASSRENDER
        bool "assrender"
+       depends on BR2_INSTALL_LIBSTDCPP # libass -> harfbuzz
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # libass -> harfbuzz
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # libass -> harfbuzz
        select BR2_PACKAGE_LIBASS
 
+comment "assrender plugin needs a toolchain w/ C++, gcc => 4.8"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_BLUEZ
        bool "bluez"
        depends on BR2_USE_WCHAR # bluez5_utils -> libglib2
index 27fa102e1f2401dc5a36f958f82ce70ac1e12b52..8bc88f42843a83bfeac64de59527b6528f065af4 100644 (file)
@@ -11,7 +11,7 @@ config BR2_PACKAGE_HARFBUZZ
          Harfbuzz can make optional use of cairo, freetype,
          glib2 and icu packages if they are selected.
 
-comment "harfbuzz needs a toolchain w/ C++, gcc => 4.8"
+comment "harfbuzz needs a toolchain w/ C++, gcc >= 4.8"
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
index 2acb2719928bf0a398514424d61bcd7b749c61c1..31ad8630d6d1043fb68be0dcbb2787bcd92604cb 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_KODI_ARCH_SUPPORTS
 
 comment "kodi needs python w/ .py modules, a uClibc or glibc toolchain w/ C++, threads, wchar, dynamic library, gcc >= 4.8"
        depends on BR2_PACKAGE_KODI_ARCH_SUPPORTS
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS \
                || !BR2_USE_WCHAR || BR2_STATIC_LIBS \
                || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
@@ -61,6 +62,7 @@ comment "kodi needs an OpenGL EGL backend with OpenGL support"
 menuconfig BR2_PACKAGE_KODI
        bool "kodi"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # libass -> harfbuzz
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on !BR2_TOOLCHAIN_USES_MUSL
index c654d8212ad2a197124d28f375edc61d4b03ffe5..803f6b443814a2a46f82302f910c75e3a5ad2cf4 100644 (file)
@@ -1,9 +1,18 @@
 config BR2_PACKAGE_LIBASS
        bool "libass"
+       depends on BR2_INSTALL_LIBSTDCPP # harfbuzz
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # harfbuzz
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 # harfbuzz
        select BR2_PACKAGE_FREETYPE
+       select BR2_PACKAGE_HARFBUZZ
        select BR2_PACKAGE_LIBFRIBIDI
        help
          libass is a portable subtitle renderer for the ASS/SSA
          (Advanced Substation Alpha/Substation Alpha) subtitle format
 
          https://github.com/libass/libass
+
+comment "libass needs a toolchain w/ C++, gcc >= 4.8"
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
+       depends on !BR2_INSTALL_LIBSTDCPP || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
index 74ea5f921dbd5a859a1157bff480ad644054ae42..cd3c3af61cfe119914436404ddd75b55624c1fe7 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 881f2382af48aead75b7a0e02e65d88c5ebd369fe46bc77d9270a94aa8fd38a2  libass-0.14.0.tar.xz
-sha256 f7e30699d02798351e7f839e3d3bfeb29ce65e44efa7735c225464c4fd7dfe9c  COPYING
+sha256  9f09230c9a0aa68ef7aa6a9e2ab709ca957020f842e52c5b2e52b801a7d9e833  libass-0.15.0.tar.xz
+sha256  f7e30699d02798351e7f839e3d3bfeb29ce65e44efa7735c225464c4fd7dfe9c  COPYING
index 50600963ed3e3f0e7f6d6d1442762a3bcb062685..818bff234e0973941345242e623608acf1833f50 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBASS_VERSION = 0.14.0
+LIBASS_VERSION = 0.15.0
 LIBASS_SOURCE = libass-$(LIBASS_VERSION).tar.xz
 # Do not use the github helper here, the generated tarball is *NOT*
 # the same as the one uploaded by upstream for the release.
@@ -15,6 +15,7 @@ LIBASS_LICENSE_FILES = COPYING
 LIBASS_DEPENDENCIES = \
        host-pkgconf \
        freetype \
+       harfbuzz \
        libfribidi \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
@@ -31,11 +32,4 @@ else
 LIBASS_CONF_OPTS += --disable-fontconfig --disable-require-system-font-provider
 endif
 
-ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
-LIBASS_DEPENDENCIES += harfbuzz
-LIBASS_CONF_OPTS += --enable-harfbuzz
-else
-LIBASS_CONF_OPTS += --disable-harfbuzz
-endif
-
 $(eval $(autotools-package))