libevent: bump to version 2.1.8
authorAdam Duskett <Aduskett@gmail.com>
Fri, 3 Feb 2017 20:29:53 +0000 (15:29 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 4 Feb 2017 16:13:07 +0000 (17:13 +0100)
I also modified the Disable-building-test-programs.patch to work
with the newer Makefile.

[Peter: add s-o-b / note to patch]
Signed-off-by: Adam Duskett <aduskett@codeblue.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libevent/0001-Disable-building-test-programs.patch
package/libevent/libevent.hash
package/libevent/libevent.mk

index eb1acfd6761858b004721c83e4427120ca2ff88c..a1ce774640d03fb6e573b5cdfba5aadd06bbadde 100644 (file)
@@ -8,6 +8,8 @@ Moreover, these programs use fork() function that is
 not available on MMU-less architectures.
 
 Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
+[aduskett@gmail.com: Updated for 2.1.8]
+Signed-off-by: Adam Duskett <aduskett@gmail.com>
 ---
  Makefile.am | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
@@ -16,12 +18,11 @@ diff --git a/Makefile.am b/Makefile.am
 index 42879a3..dc90359 100644
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -126,7 +126,7 @@ else
- noinst_LTLIBRARIES =  $(LIBEVENT_LIBS_LA)
- endif
--SUBDIRS = . include sample test
-+SUBDIRS = . include sample
+@@ -144,7 +144,6 @@
+ BUILT_SOURCES =
+ include include/include.am
+ include sample/include.am
+-include test/include.am
  
  if BUILD_WIN32
  
index 633cf5b8fa52d990cea7717fb308d774bb39a892..21381c87b3330ed2763e89e340540b47d5aa6f03 100644 (file)
@@ -1,3 +1,3 @@
-# From http://sourceforge.net/projects/levent/files/libevent/libevent-2.0/
-md5    c4c56f986aa985677ca1db89630a2e11        libevent-2.0.22-stable.tar.gz
-sha1   a586882bc93a208318c70fc7077ed8fca9862864        libevent-2.0.22-stable.tar.gz
+# locally computed
+md5    f3eeaed018542963b7d2416ef1135ecc        libevent-2.1.8-stable.tar.gz
+sha1   2a1b8bb7a262d3fd0ed6a080a20991a6eed675ec        libevent-2.1.8-stable.tar.gz
index 820beea9c54d6acfeefa1e2a74a37ecef2ab8211..0a5417f98bc4b0bb8096b92af881dcf79f55dc3c 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBEVENT_VERSION = 2.0.22-stable
+LIBEVENT_VERSION = 2.1.8-stable
 LIBEVENT_SITE = https://github.com/libevent/libevent/releases/download/release-$(LIBEVENT_VERSION)
 LIBEVENT_INSTALL_STAGING = YES
 LIBEVENT_LICENSE = BSD-3c, OpenBSD