libedbus: add options for bluez/connman/notify support
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Apr 2012 21:38:19 +0000 (23:38 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 18 Apr 2012 21:38:19 +0000 (23:38 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libedbus/Config.in
package/efl/libedbus/libedbus.mk

index 3844b52c14d770b903474537b5d0dad2b6955358..0914b37a9d6a38037fb6a717c304880226bbafe3 100644 (file)
@@ -2,10 +2,31 @@ config BR2_PACKAGE_LIBEDBUS
        bool "libedbus"
        select BR2_PACKAGE_LIBEINA
        select BR2_PACKAGE_LIBECORE
-       depends on BR2_PACKAGE_DBUS
+       select BR2_PACKAGE_DBUS
        help
          E_Dbus is a set of wrappers around D-Bus APIs so they can be
          easily used by EFL applications, automatically providing
          Ecore/main loop integration, as well as Eina data types.
 
          http://trac.enlightenment.org/e/wiki/E_Dbus
+
+if BR2_PACKAGE_LIBEDBUS
+
+config BR2_PACKAGE_LIBEDBUS_BLUEZ
+       bool "bluez support"
+       select BR2_PACKAGE_BLUEZ_UTILS
+       help
+         Bluetooth support.
+
+config BR2_PACKAGE_LIBEDBUS_CONNMAN
+       bool "connman support"
+       depends on BR2_PACKAGE_CONNMAN
+       help
+         Connection manager support.
+
+config BR2_PACKAGE_LIBEDBUS_NOTIFY
+       bool "notify support"
+       help
+         Notify support.
+
+endif
index 34f34a7c042a65899ae19ac13b066b8ca4a0d77c..c03474d9dc4938b666e8d52f0aaa138eff955113 100644 (file)
@@ -11,4 +11,24 @@ LIBEDBUS_INSTALL_STAGING = YES
 
 LIBEDBUS_DEPENDENCIES = host-pkg-config dbus libeina libecore
 
+ifeq ($(BR2_PACKAGE_LIBEDBUS_BLUEZ),y)
+LIBEDBUS_CONF_OPT += --enable-ebluez
+LIBEDBUS_DEPENDENCIES += bluez_utils
+else
+LIBEDBUS_CONF_OPT += --disable-ebluez
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_CONNMAN),y)
+LIBEDBUS_CONF_OPT += --enable-econnman0_7x
+LIBEDBUS_DEPENDENCIES += connman
+else
+LIBEDBUS_CONF_OPT += --disable-econnman0_7x
+endif
+
+ifeq ($(BR2_PACKAGE_LIBEDBUS_NOTIFY),y)
+LIBEDBUS_CONF_OPT += --enable-enotify --disable-edbus-notify-test
+else
+LIBEDBUS_CONF_OPT += --disable-enotify
+endif
+
 $(eval $(call AUTOTARGETS))