vlc: fix build when Qt4 development files are installed on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Oct 2014 21:11:07 +0000 (23:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 10 Oct 2014 21:57:45 +0000 (23:57 +0200)
When Qt4 development files are installed on the host, VLC uses
/usr/bin/moc, /usr/bin/uic and /usr/bin/rcc when Qt support is
enabled. However, those host installed versions are not necessarily
compatible with the Qt version used in Buildroot, causes some build
failures.

This commit therefore passes explicit ac_cv_path_MOC, ac_cv_path_RCC
and ac_cv_path_UIC variables to make sure the Qt host tools built by
Buildroot are used.

Note that the VLC configure.ac script uses 'pkg-config
--variable=exec_prefix QtCore' to find the location of such tools, but
this invocation returns /usr. One solution would have been to extend
the pkgconf-01-fix-variable.patch we have against pkgconf to also
cover exec_prefix, but this has more uncertain consequences than just
fixing VLC.

Fixes:

  http://autobuild.buildroot.org/results/061/06174eaeb7f2b8a591395e607912ad72623b79e3/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index 0b275f2ba73851ad00f2424e508903b9649ef1e3..13c72ce8ce0f0be9bb3b0ad7673b8813f2ad325b 100644 (file)
@@ -251,6 +251,10 @@ endif
 
 ifeq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
 VLC_CONF_OPTS += --enable-qt
+VLC_CONF_ENV += \
+       ac_cv_path_MOC=$(HOST_DIR)/usr/bin/moc \
+       ac_cv_path_RCC=$(HOST_DIR)/usr/bin/rcc \
+       ac_cv_path_UIC=$(HOST_DIR)/usr/bin/uic
 VLC_DEPENDENCIES += qt
 else
 VLC_CONF_OPTS += --disable-qt