external-toolchain: recognize uClibc 64 bits toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 Jul 2010 16:59:00 +0000 (18:59 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 6 Jul 2010 05:59:39 +0000 (07:59 +0200)
With uClibc 64 bits toolchain, the dynamic loader is named
ld64-uClibc.so.0 and not ld-uClibc.so.0. So, this commit adjust the
uClibc detection code for external toolchains.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Yann E. MORIN <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/external-toolchain/ext-tool.mk

index d5917811685df559c6b260ca8c8eba5fc538c513..39961843e90655e37a6a4b825852f278eeac6821 100644 (file)
@@ -216,7 +216,7 @@ check_uclibc_feature = \
 #
 check_uclibc = \
        SYSROOT_DIR="$(strip $1)"; \
-       if ! test -f $${SYSROOT_DIR}/lib/ld-uClibc.so.* ; then \
+       if ! test -f $${SYSROOT_DIR}/lib/ld*-uClibc.so.* ; then \
                echo "Incorrect selection of the C library"; \
                exit -1; \
        fi; \