toolchain/helper: update check_unusable_toolchain comment
authorRomain Naour <romain.naour@gmail.com>
Wed, 27 Apr 2016 20:15:03 +0000 (22:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 27 Apr 2016 20:19:19 +0000 (22:19 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/helpers.mk

index 4548eded354f9452947d4d30091c6f9904bb7b6d..d28a2caed3ea848edb2e3fc6dbbf75077e2fabf4 100644 (file)
@@ -348,9 +348,12 @@ check_cross_compiler_exists = \
        fi
 
 #
-# Check for toolchains known not to work with Buildroot. For now, we
-# only check for Angstrom toolchains, by looking at the vendor part of
-# the host tuple.
+# Check for toolchains known not to work with Buildroot.
+# - For the Angstrom toolchains, we check by looking at the vendor part of
+#   the host tuple.
+# - Exclude distro-class toolchains which are not relocatable.
+# - Exclude broken toolchains which return "libc.a" with -print-file-name.
+# - Exclude toolchains which doesn't support --sysroot option.
 #
 # $1: cross-gcc path
 #