lualogging: new package
authorFrancois Perrad <fperrad@gmail.com>
Mon, 24 Feb 2014 07:34:49 +0000 (08:34 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 15:07:09 +0000 (16:07 +0100)
[Thomas: simplify version specification in the .mk file.]

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/lualogging/Config.in [new file with mode: 0644]
package/lualogging/lualogging.mk [new file with mode: 0644]

index cc44228208047decfb687fde64fade6e93433ec1..c4cdcc487c3e24cd7e3eb539023680fb8011a5cb 100644 (file)
@@ -385,6 +385,7 @@ source "package/luaexpat/Config.in"
 source "package/luaexpatutils/Config.in"
 source "package/luafilesystem/Config.in"
 source "package/luajson/Config.in"
+source "package/lualogging/Config.in"
 source "package/luaposix/Config.in"
 source "package/luasec/Config.in"
 source "package/luasocket/Config.in"
diff --git a/package/lualogging/Config.in b/package/lualogging/Config.in
new file mode 100644 (file)
index 0000000..37d7015
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_LUALOGGING
+       bool "lualogging"
+       help
+         LuaLogging provides a simple API to use logging features in Lua.
+         Its design was based on log4j. LuaLogging currently supports,
+         through the use of appenders, console, file, rolling file, email,
+         socket and SQL outputs.
+
+         http://www.keplerproject.org/lualogging/
diff --git a/package/lualogging/lualogging.mk b/package/lualogging/lualogging.mk
new file mode 100644 (file)
index 0000000..d17353c
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# lualogging
+#
+################################################################################
+
+LUALOGGING_VERSION = 1.3.0-1
+LUALOGGING_SUBDIR  = lualogging
+LUALOGGING_LICENSE = MIT
+LUALOGGING_LICENSE_FILES = $(LUALOGGING_SUBDIR)/COPYRIGHT
+
+$(eval $(luarocks-package))