package/Makefile.in: don't force jobs when BR2_JLEVEL is empty
authorFabio Porcedda <fabio.porcedda@gmail.com>
Thu, 3 Oct 2013 12:10:42 +0000 (14:10 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Oct 2013 13:08:30 +0000 (15:08 +0200)
When the "BR2_JLEVEL" variable is empty use "make" without
the "-j" option, because to be able to use top-level parallel
make we must not force the number of jobs in sub-make.

Example:
make BR2_JLEVEL= -j8

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Makefile.in

index 170ad789b0d5b83fe9810937bbb95bce3a46217c..d406901ade16c068ce8920cc8aec045fc7c39dc0 100644 (file)
@@ -18,7 +18,7 @@ PARALLEL_JOBS:=$(BR2_JLEVEL)
 endif
 
 MAKE1:=$(HOSTMAKE) -j1
-MAKE:=$(HOSTMAKE) -j$(PARALLEL_JOBS)
+MAKE:=$(HOSTMAKE) $(if $(PARALLEL_JOBS),-j$(PARALLEL_JOBS))
 
 # Compute GNU_TARGET_NAME
 GNU_TARGET_NAME=$(ARCH)-buildroot-$(TARGET_OS)-$(LIBC)$(ABI)