drbd-utils: new package
authorChristophe Vu-Brugier <cvubrugier@fastmail.fm>
Thu, 12 Mar 2015 16:33:16 +0000 (17:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 12:36:52 +0000 (14:36 +0200)
DRBD utilities to manage the DRBD kernel module.

[Thomas: remove largefile dependency.]

Signed-off-by: Christophe Vu-Brugier <cvubrugier@fastmail.fm>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/drbd-utils/Config.in [new file with mode: 0644]
package/drbd-utils/drbd-utils.mk [new file with mode: 0644]

index f00a18ff18d6a3cf027328152f5fc94d9ea52fc5..65e268353f5462a04f4981d63cb8ee1173eda174 100644 (file)
@@ -1114,6 +1114,7 @@ endif
        source "package/dhcpcd/Config.in"
        source "package/dhcpdump/Config.in"
        source "package/dnsmasq/Config.in"
+       source "package/drbd-utils/Config.in"
        source "package/dropbear/Config.in"
        source "package/ebtables/Config.in"
        source "package/ejabberd/Config.in"
diff --git a/package/drbd-utils/Config.in b/package/drbd-utils/Config.in
new file mode 100644 (file)
index 0000000..be68619
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_DRBD_UTILS
+       bool "drbd-utils"
+       depends on BR2_USE_MMU # needs fork()
+       help
+         DRBD utilities to manage the DRBD kernel module.
+
+         http://oss.linbit.com/drbd/
diff --git a/package/drbd-utils/drbd-utils.mk b/package/drbd-utils/drbd-utils.mk
new file mode 100644 (file)
index 0000000..0da4b1f
--- /dev/null
@@ -0,0 +1,34 @@
+################################################################################
+#
+# drbd-utils
+#
+################################################################################
+
+DRBD_UTILS_VERSION = 8.9.1
+DRBD_UTILS_SITE = http://oss.linbit.com/drbd/
+DRBD_UTILS_LICENSE = GPLv2+
+DRBD_UTILS_LICENSE_FILES = COPYING
+
+DRBD_UTILS_CONF_OPTS = --with-distro=generic
+
+ifeq ($(BR2_INIT_SYSTEMD),y)
+DRBD_UTILS_CONF_OPTS += --with-initscripttype=systemd
+DRDB_UTILS_DEPENDENCIES += systemd
+else
+DRBD_UTILS_CONF_OPTS += --with-initscripttype=sysv
+endif
+
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
+DRBD_UTILS_CONF_OPTS += --with-udev=yes
+DRDB_UTILS_DEPENDENCIES += udev
+else
+DRBD_UTILS_CONF_OPTS += --with-udev=no
+endif
+
+# Do not build the documentation because it requires docbook
+define DRBD_UTILS_DISABLE_DOCS
+       $(SED) 's/user scripts documentation/user scripts/' $(@D)/Makefile.in
+endef
+DRBD_UTILS_POST_PATCH_HOOKS += DRBD_UTILS_DISABLE_DOCS
+
+$(eval $(autotools-package))