toolchain/crosstool-NG: correctly copy the dynamic linker
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Sat, 23 Apr 2011 16:18:34 +0000 (18:18 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 20:37:37 +0000 (22:37 +0200)
Depending on some setting (which? Arch? Others?), the dynamic linker
can get different names. Some times, it is named ld-linux.something.so,
other times, it is ld.so.1, and maybe other variants as well...

The fix is to always copy ls*.so, even if it is a symlink: we create
the destination file by its SONAME, and if ld*.so matches more than
one file, that's no issue, as they would all get the same SONAME (being
symlinks ones to the others).

Split long lines at the same time.

Reported-by: Ettore Campion <ecampion@gmail.com>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-crosstool-ng/crosstool-ng.mk

index e52bdee25d088202a655407f521b460fcc8bb5e3..015cd13e63957074b066a27591f03246ab84d3c4 100644 (file)
@@ -36,13 +36,14 @@ endef
 
 #--------------
 # The generic system libraries (in /lib)
-CTNG_LIBS_LIB := libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthread.so libresolv.so librt.so libutil.so
+CTNG_LIBS_LIB := ld*.so libc.so libcrypt.so libdl.so libgcc_s.so libm.so    \
+                 libnsl.so libpthread.so libresolv.so librt.so libutil.so
 
 #--------------
 # The libc-specific system libraries (in /lib)
 # Note: it may be needed to tweak the NSS libs in the glibc and eglibc cases...
-CTNG_LIBS_uClibc := ld-uClibc.so
-CTNG_LIBS_glibc  := ld-linux.so libnss_files.so libnss_dns.so
+CTNG_LIBS_uClibc :=
+CTNG_LIBS_glibc  := libnss_files.so libnss_dns.so
 CTNG_LIBS_eglibc := $(CTNG_LIBS_glibc)
 
 #--------------