libnl: bump to version 3.2.9 and enhance
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 14 May 2012 02:29:58 +0000 (02:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 May 2012 19:37:06 +0000 (21:37 +0200)
Bump to version 3.2.9 and add an option to install the tools.
Since they're not usually required we default to N to reduce size.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libnl/Config.in
package/libnl/libnl.mk

index 24e481361cfc8102444ff9eef974c14193b5d747..c7d435983b15a8e1d9442493cb4472cfc213f90b 100644 (file)
@@ -4,3 +4,9 @@ config BR2_PACKAGE_LIBNL
          A library for applications dealing with netlink socket.
 
          http://people.suug.ch/~tgr/libnl/
+
+config BR2_PACKAGE_LIBNL_TOOLS
+       bool "install tools"
+       depends on BR2_PACKAGE_LIBNL
+       help
+         Install binary tools.
index 40aaf388efa4dca359fb00f950093e1a67f44c06..a7237016654cdea43f1f1e021bb0a4d4e159051e 100644 (file)
@@ -4,15 +4,26 @@
 #
 #############################################################
 
-LIBNL_VERSION = 3.2.8
+LIBNL_VERSION = 3.2.9
 LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files
 LIBNL_INSTALL_STAGING = YES
 LIBNL_DEPENDENCIES = host-bison
 LIBNL_MAKE = $(MAKE1)
+LIBNL_BINARIES = class-add class-delete class-list classid-lookup cls-add \
+       cls-delete cls-list link-list pktloc-lookup qdisc-add qdisc-delete \
+       qdisc-list
 
 define LIBNL_UNINSTALL_TARGET_CMDS
        rm -r $(TARGET_DIR)/usr/lib/libnl.* $(TARGET_DIR)/usr/lib/libnl-*.*
        rm -rf $(TARGET_DIR)/usr/lib/libnl
 endef
 
+define LIBNL_REMOVE_TOOLS
+       rm -rf $(addprefix $(TARGET_DIR)/usr/sbin/nl-, $(LIBNL_BINARIES))
+endef
+
+ifneq ($(BR2_PACKAGE_LIBNL_TOOLS),y)
+LIBNL_POST_INSTALL_TARGET_HOOKS += LIBNL_REMOVE_TOOLS
+endif
+
 $(eval $(call AUTOTARGETS))