qt5base: remove now-redundant ccache handling
authorArnout Vandecappelle <arnout@mind.be>
Sun, 4 Oct 2015 12:28:52 +0000 (13:28 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 4 Oct 2015 16:22:20 +0000 (18:22 +0200)
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/0002-mkspecs-files.patch
package/qt5/qt5base/0009-fix-build-with-ccache.patch [deleted file]
package/qt5/qt5base/qt5base.mk

index 09c1b67c11329fd4230df5f8e7a6262c95bee6b9..adeabdfbd88ba7050be80a7a555a5272aa6b3d6c 100644 (file)
@@ -9,6 +9,8 @@ allows us to easily pass the cross-compiler paths and flags from our
 qt5.mk.
 
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+[Arnout: remove ccache support]
+Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
 
 Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
 ===================================================================
@@ -18,8 +20,8 @@ Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
 +include(../common/linux_device_pre.conf)
 +
 +# modifications to g++-unix.conf
-+QMAKE_CC                = $${BR_CCACHE} $${CROSS_COMPILE}gcc
-+QMAKE_CXX               = $${BR_CCACHE} $${CROSS_COMPILE}g++
++QMAKE_CC                = $${CROSS_COMPILE}gcc
++QMAKE_CXX               = $${CROSS_COMPILE}g++
 +
 +#modifications to gcc-base.conf
 +QMAKE_CFLAGS           += $${BR_COMPILER_CFLAGS}
diff --git a/package/qt5/qt5base/0009-fix-build-with-ccache.patch b/package/qt5/qt5base/0009-fix-build-with-ccache.patch
deleted file mode 100644 (file)
index 896c0ef..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-Fix QMAKE_CXX/CROSS_COMPILE verification with ccache
-
-The use of ccache leads to QMAKE_CXX definitions of the form:
-
-    QMAKE_CXX = $${CCACHE} $${CROSS_COMPILE}g++
-
-The previous test required QMAKE_CXX to be a single valid (absolute or
-QMAKE_PATH_ENV-relative) path to an existing file, which was not
-compatible with definitions of QMAKE_CXX like the one above.
-
-Fix this by using only the first value in QMAKE_CXX, which usually
-points to the compiler executable, or to the ccache executable in the
-above case.
-
-Signed-off-by: Benoît Thébaudeau <benoit@wsystem.com>
----
- mkspecs/features/device_config.prf | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/mkspecs/features/device_config.prf b/mkspecs/features/device_config.prf
-index cd3a0cf..eee4ac6 100644
---- a/mkspecs/features/device_config.prf
-+++ b/mkspecs/features/device_config.prf
-@@ -19,10 +19,15 @@ defineTest(deviceSanityCheckCompiler) {
-     else: \
-         sfx =
-+    # Build the compiler filename using the first value in QMAKE_CXX in order to
-+    # support tools like ccache, which give QMAKE_CXX values of the form:
-+    #     ccache <path_to_compiler>
-+    compiler = $$first(QMAKE_CXX)$$sfx
-+
-     # Check if the binary exists with an absolute path. Do this check
-     # before the CROSS_COMPILE empty check below to allow the mkspec
-     # to derive the compiler path from other device options.
--    exists($$QMAKE_CXX$$sfx):return()
-+    exists($$compiler):return()
-     # Check for possible reasons of failure
-     # check if CROSS_COMPILE device-option is set
-@@ -31,7 +36,7 @@ defineTest(deviceSanityCheckCompiler) {
-     # Check if QMAKE_CXX points to an executable.
-     ensurePathEnv()
-     for (dir, QMAKE_PATH_ENV) {
--        exists($$dir/$${QMAKE_CXX}$$sfx): \
-+        exists($$dir/$${compiler}): \
-             return()
-     }
index e783b4d42e3ffa32e36a8c637a5ded7b5ae5924e..570cd35d0c9ecbee19b231c96246d7a2a43aa94a 100644 (file)
@@ -189,7 +189,6 @@ define QT5BASE_CONFIGURE_CMDS
                -nomake tests \
                -device buildroot \
                -device-option CROSS_COMPILE="$(TARGET_CROSS)" \
-               -device-option BR_CCACHE="$(CCACHE)" \
                -device-option BR_COMPILER_CFLAGS="$(TARGET_CFLAGS) $(QT5BASE_EXTRA_CFLAGS)" \
                -device-option BR_COMPILER_CXXFLAGS="$(TARGET_CXXFLAGS) $(QT5BASE_EXTRA_CFLAGS)" \
                $(QT5BASE_CONFIGURE_OPTS) \