host-cmake: Install with install/fast target
authorCédric Marie <cedric.marie@openmailbox.org>
Thu, 23 Apr 2015 19:46:13 +0000 (21:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Apr 2015 20:59:43 +0000 (22:59 +0200)
Use install/fast target in order to skip compilation in installation
step. The same trick has just been used in pkg-cmake.mk for all CMake
packages.

Signed-off-by: Cédric Marie <cedric.marie@openmailbox.org>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cmake/cmake.mk

index 6b9e56386919388b31dde5f06ddb6716affa5662..9ca6443a4e5f1c152b5cc627f3c2e329496a151a 100644 (file)
@@ -44,7 +44,7 @@ define HOST_CMAKE_BUILD_CMDS
 endef
 
 define HOST_CMAKE_INSTALL_CMDS
-       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install/fast
 endef
 
 define CMAKE_REMOVE_EXTRA_DATA