package/procps-ng: if building with systemd, enable systemd-specific features
authorSteven Noonan <steven@uplinklabs.net>
Wed, 18 Mar 2015 21:44:42 +0000 (14:44 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Apr 2015 15:29:19 +0000 (17:29 +0200)
[Thomas: add explicit --without-systemd option when systemd is not
available.]

Signed-off-by: Steven Noonan <steven@uplinklabs.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/procps-ng/procps-ng.mk

index ff3c6d32efa78b220f9a4e6b8899f1fc2c2e292a..b1c17c0b360eeb709a25c3629d7d8bbac8bb3d28 100644 (file)
@@ -24,6 +24,13 @@ PROCPS_NG_DEPENDENCIES += gettext
 PROCPS_NG_CONF_OPTS += LIBS=-lintl
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+PROCPS_NG_DEPENDENCIES += systemd
+PROCPS_NG_CONF_OPTS += --with-systemd
+else
+PROCPS_NG_CONF_OPTS += --without-systemd
+endif
+
 # We need this to make procps-ng binaries installed in $(TARGET_DIR)/usr
 # instead of $(TARGET_DIR)/usr/usr
 PROCPS_NG_CONF_OPTS += --exec-prefix=