projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a25df76
)
netsnmp: fix static linking with openssl
author
Peter Korsgaard
<peter@korsgaard.com>
Sat, 15 Feb 2014 08:18:35 +0000
(09:18 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Sat, 15 Feb 2014 08:18:35 +0000
(09:18 +0100)
Fixes http://autobuild.buildroot.net/results/084/
0845bde5d234bd00d23c7a1b7e18746882dcdde4
/
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netsnmp/netsnmp.mk
patch
|
blob
|
history
diff --git
a/package/netsnmp/netsnmp.mk
b/package/netsnmp/netsnmp.mk
index 6bb6fe251f487edefabc1811c0d4fb921181baa2..4830c00e858109db0184d02de546134821f3f958 100644
(file)
--- a/
package/netsnmp/netsnmp.mk
+++ b/
package/netsnmp/netsnmp.mk
@@
-40,6
+40,10
@@
ifeq ($(BR2_PACKAGE_OPENSSL),y)
NETSNMP_DEPENDENCIES += openssl
NETSNMP_CONF_OPT += \
--with-openssl=$(STAGING_DIR)/usr/include/openssl
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+ # openssl uses zlib, so we need to explicitly link with it when static
+ NETSNMP_CONF_ENV += LIBS=-lz
+endif
else
NETSNMP_CONF_OPT += --without-openssl
endif