package/poco: Update check for uclibc toolchain
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 17 Sep 2017 17:58:18 +0000 (19:58 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 13:44:11 +0000 (15:44 +0200)
LIBC is really only used to construct the target tuple. To check if we
are using a uClibc toolchain, we use BR2_TOOLCHAIN_USES_UCLIBC.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/poco/poco.mk

index 673b93a4f999415cab1f885b3635dbb7ac312048..29752e24c9dccc7f2b63268c20aa47773f262147 100644 (file)
@@ -28,7 +28,7 @@ POCO_OMIT = Data/ODBC PageCompiler \
        $(if $(BR2_PACKAGE_POCO_DATA_MYSQL),,Data/MySQL) \
        $(if $(BR2_PACKAGE_POCO_DATA_SQLITE),,Data/SQLite)
 
-ifeq ($(LIBC),uclibc)
+ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 POCO_CONF_OPTS += --no-fpenvironment --no-wstring
 endif