Makefile: make help: show busybox/ctng/linux/uclibc-menuconfig if enabled
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 22:10:45 +0000 (00:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Apr 2011 22:10:45 +0000 (00:10 +0200)
For this we need to read .config.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 98cc09f9323bc87de4bd78579e0fb12809d54ac9..d4f5e151379fb65c3110768c6377faf7175971d4 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -42,7 +42,7 @@ export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion
 noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
        defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
        randpackageconfig allyespackageconfig allnopackageconfig \
-       source-check help
+       source-check
 
 # Strip quotes and then whitespaces
 qstrip=$(strip $(subst ",,$(1)))
@@ -661,6 +661,18 @@ help:
        @echo '  randpackageconfig      - New config with random answer to package options'
        @echo '  allyespackageconfig    - New config where pkg options are accepted with yes'
        @echo '  allnopackageconfig     - New config where package options are answered with no'
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+       @echo '  busybox-menuconfig     - Run BusyBox menuconfig'
+endif
+ifeq ($(BR2_LINUX_KERNEL),y)
+       @echo '  linux-menuconfig       - Run Linux kernel menuconfig'
+endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+       @echo '  uclibc-menuconfig      - Run uClibc menuconfig'
+endif
+ifeq ($(BR2_TOOLCHAIN_CTNG),y)
+       @echo '  ctng-menuconfig        - Run crosstool-NG menuconfig'
+endif
        @echo
        @echo 'Miscellaneous:'
        @echo '  source                 - download all sources needed for offline-build'