package: add bonnie++
authorMartin Hicks <mort@bork.org>
Mon, 31 Jan 2011 20:32:06 +0000 (15:32 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Apr 2011 09:39:48 +0000 (11:39 +0200)
Closes #3379

A good filesystem performance benchmark program

Signed-off-by: Martin Hicks <mort@bork.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/bonnie/Config.in [new file with mode: 0644]
package/bonnie/bonnie.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 19d2cc518f90e78d70168be78c343ba4d1c35629..0b1189861c064363de633801ee7a3a631572f86c 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -9,10 +9,11 @@
        quagga, readline, rsync, samba, squid, socat, squashfs, tslib,
        webkit, xerces, xlib_xtrans, xorg-server, xterm, xz
 
-       New packages: can-utils, htop, libv4l
+       New packages: bonnie++, can-utils, htop, libv4l
 
        Issues resolved (http://bugs.uclibc.org):
 
+       #3379: New Package: bonnie++
        #3445: Not working openssl-10.0.0d on 386sx
        #3451: fakeroot package: wrong FAKEROOT_SITE variable
        #3457: alsamixergui: broken URL
index 71dc0a80a4b1625f79e763dbfb90b00466802ae7..b5a1ee4f6c21a020e0f27e0dd67980a2feb2bd3e 100644 (file)
@@ -17,6 +17,7 @@ source "package/xz/Config.in"
 endmenu
 
 menu "Debugging, profiling and benchmark"
+source "package/bonnie/Config.in"
 source "package/dhrystone/Config.in"
 source "package/dmalloc/Config.in"
 source "package/kexec/Config.in"
diff --git a/package/bonnie/Config.in b/package/bonnie/Config.in
new file mode 100644 (file)
index 0000000..9dda4b6
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_BONNIE
+       bool "bonnie++"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Filesystem tester
+
+         http://www.coker.com.au/bonnie++/
+
+comment "bonnie++ requires a toolchain with C++ support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/bonnie/bonnie.mk b/package/bonnie/bonnie.mk
new file mode 100644 (file)
index 0000000..9a6188f
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# bonnie++
+#
+
+BONNIE_VERSION = 1.03e
+BONNIE_SOURCE = bonnie++-$(BONNIE_VERSION).tgz
+BONNIE_SITE = http://www.coker.com.au/bonnie++/
+
+define BONNIE_INSTALL_TARGET_CMDS
+       install -D -m 755 $(@D)/bonnie++ $(TARGET_DIR)/usr/sbin/bonnie++
+       install -D -m 755 $(@D)/zcav $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+define BONNIE_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/usr/sbin/bonnie++ $(TARGET_DIR)/usr/sbin/zcav
+endef
+
+$(eval $(call AUTOTARGETS,package,bonnie))