package/libarchive: add zstd optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 28 Feb 2020 22:12:36 +0000 (23:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 19:21:35 +0000 (21:21 +0200)
zstd is available since version 3.3.3 and
https://github.com/libarchive/libarchive/commit/26838cf5c17642f57192753cc5c3880b16b65ba3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libarchive/libarchive.mk

index 20863f9ba989bf1b80764af4ab72061675555496..516d929763a9ddbdadd0259930e97c8460c5f8ce 100644 (file)
@@ -111,6 +111,13 @@ else
 LIBARCHIVE_CONF_OPTS += --without-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_ZSTD),y)
+LIBARCHIVE_CONF_OPTS += --with-zstd
+LIBARCHIVE_DEPENDENCIES += zstd
+else
+LIBARCHIVE_CONF_OPTS += --without-zstd
+endif
+
 # libarchive requires LZMA with thread support in the toolchain
 ifeq ($(BR2_TOOLCHAIN_HAS_THREADS)$(BR2_PACKAGE_XZ),yy)
 LIBARCHIVE_DEPENDENCIES += xz
@@ -143,7 +150,8 @@ HOST_LIBARCHIVE_CONF_OPTS = \
        --without-mbedtls \
        --without-nettle \
        --without-openssl \
-       --without-lzma
+       --without-lzma \
+       --without-zstd
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))