target/cpio: cleanup
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Mar 2010 21:39:25 +0000 (22:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:32 +0000 (11:04 +0200)
 * Remove the dependency on BR2_HOST_FAKEROOT, since we don't have
   config option for host tools.

 * Remove a few useless things.

 * Check that cpio is available on the host in
   toolchain/dependencies/dependencies.sh.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/cpio/Config.in
target/cpio/cpioroot.mk
toolchain/dependencies/dependencies.sh

index 83bdd21e046ca054666c8938ffc955c6f5413d09..4ee1037d4ac86edf74e7401d26d0a0124cc95766 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_TARGET_ROOTFS_CPIO
        bool "cpio the root filesystem"
-       select BR2_HOST_FAKEROOT
        help
          Build a cpio archive of the root filesystem
 
index 2197d10506682457f62e6d341e0cc598d656d31d..021847ffd5703bceb9c889341c74dea41f942b42 100644 (file)
@@ -12,17 +12,15 @@ CPIO_ROOTFS_COMPRESSOR_PREREQ:=
 ifeq ($(BR2_TARGET_ROOTFS_CPIO_GZIP),y)
 CPIO_ROOTFS_COMPRESSOR:=gzip -9 -c
 CPIO_ROOTFS_COMPRESSOR_EXT:=gz
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= gzip-host
 endif
 ifeq ($(BR2_TARGET_ROOTFS_CPIO_BZIP2),y)
 CPIO_ROOTFS_COMPRESSOR:=bzip2 -9 -c
 CPIO_ROOTFS_COMPRESSOR_EXT:=bz2
-#CPIO_ROOTFS_COMPRESSOR_PREREQ:= bzip2-host
 endif
 ifeq ($(BR2_TARGET_ROOTFS_CPIO_LZMA),y)
-CPIO_ROOTFS_COMPRESSOR:=lzma -9 -c
+CPIO_ROOTFS_COMPRESSOR:=$(LZMA) -9 -c
 CPIO_ROOTFS_COMPRESSOR_EXT:=lzma
-CPIO_ROOTFS_COMPRESSOR_PREREQ:= lzma-host
+CPIO_ROOTFS_COMPRESSOR_PREREQ:= host-lzma
 endif
 
 ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
@@ -32,7 +30,6 @@ CPIO_TARGET := $(CPIO_BASE)
 endif
 
 ROOTFS_CPIO_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_CPIO_COPYTO))
-#
 
 cpioroot-init:
        rm -f $(TARGET_DIR)/init
@@ -54,7 +51,7 @@ endif
                >> $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-       #-@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
+       -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
 ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
 ifneq ($(ROOTFS_CPIO_COPYTO),)
        $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
@@ -69,14 +66,6 @@ ifneq ($(ROOTFS_CPIO_COPYTO),)
 endif
 endif
 
-cpioroot: $(CPIO_TARGET)
-
-cpioroot-source:
-
-cpioroot-clean:
-
-cpioroot-dirclean:
-
 #############################################################
 #
 # Toplevel Makefile options
index 68b275176263aec1e7c56d9852bea6aa0608823e..013c1d57d3c75a4eacb6017685d3de53fbc421c0 100755 (executable)
@@ -122,7 +122,7 @@ if ! $SHELL --version 2>&1 | grep -q '^GNU bash'; then
 fi;
 
 # Check that a few mandatory programs are installed
-for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget ; do
+for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio ; do
     if ! which $prog > /dev/null ; then
        /bin/echo -e "\nYou must install '$prog' on your build machine";
        if test $prog = "makeinfo" ; then