network-manager: add optional concheck support
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 11 May 2017 13:56:38 +0000 (14:56 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 11 May 2017 19:18:01 +0000 (21:18 +0200)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/network-manager/network-manager.mk

index 1d17ec41811673edca6805df2f2e400e58c9ed9c..9f4cebe12b68f1571bce1bf135b47d295798444e 100644 (file)
@@ -30,8 +30,14 @@ NETWORK_MANAGER_CONF_OPTS = \
        --with-crypto=gnutls \
        --with-iptables=/usr/sbin/iptables \
        --disable-ifupdown \
-       --disable-ifnet \
-       --disable-concheck
+       --disable-ifnet
+
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
+NETWORK_MANAGER_DEPENDENCIES += libcurl
+NETWORK_MANAGER_CONF_OPTS += --enable-concheck
+else
+NETWORK_MANAGER_CONF_OPTS += --disable-concheck
+endif
 
 ifeq ($(BR2_PACKAGE_NETWORK_MANAGER_TUI),y)
 NETWORK_MANAGER_DEPENDENCIES += newt