package/enet: new package
authorRomain Naour <romain.naour@gmail.com>
Mon, 22 Apr 2019 17:10:47 +0000 (19:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 24 Apr 2019 20:48:16 +0000 (22:48 +0200)
enet will be used by supertuxkart 1.0.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/enet/Config.in [new file with mode: 0644]
package/enet/enet.hash [new file with mode: 0644]
package/enet/enet.mk [new file with mode: 0644]

index e5b69c3ade655a3e96d8f34b7d279fab4a5be1f0..56556413aa7d10a9f847af701caf50199e83ee13 100644 (file)
@@ -1917,6 +1917,7 @@ N:        Romain Naour <romain.naour@gmail.com>
 F:     package/aubio/
 F:     package/bullet/
 F:     package/efl/
+F:     package/enet/
 F:     package/enlightenment/
 F:     package/flare-engine/
 F:     package/flare-game/
index 091b16d02d2d7c532ab63332604257ecb44b6177..f592e74a995df0e1a127583eff317dc3b9b12093 100644 (file)
@@ -1532,6 +1532,7 @@ menu "Networking"
        source "package/czmq/Config.in"
        source "package/daq/Config.in"
        source "package/davici/Config.in"
+       source "package/enet/Config.in"
        source "package/filemq/Config.in"
        source "package/flickcurl/Config.in"
        source "package/fmlib/Config.in"
diff --git a/package/enet/Config.in b/package/enet/Config.in
new file mode 100644 (file)
index 0000000..ef3f152
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_ENET
+       bool "enet"
+       help
+         ENet's purpose is to provide a relatively thin, simple
+         and robust network communication layer on top of UDP
+         (User Datagram Protocol).The primary feature it
+         provides is optional reliable, in-order delivery of
+         packets.
+
+         ENet omits certain higher level networking features
+         such as authentication, lobbying, server discovery,
+         encryption, or other similar tasks that are
+         particularly application specific so that the library
+         remains flexible, portable, and easily embeddable.
+
+         http://enet.bespin.org
diff --git a/package/enet/enet.hash b/package/enet/enet.hash
new file mode 100644 (file)
index 0000000..ed5231c
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 98f6f57aab0a424469619ed3047728f0d3901ce8f0dea919c11e7966d807e870  enet-1.3.14.tar.gz
+sha256 eebe647a9ef7e596b0e8b9216c215f169d762af1a27904a87bc2e05b83735d35  LICENSE
diff --git a/package/enet/enet.mk b/package/enet/enet.mk
new file mode 100644 (file)
index 0000000..b12c1b6
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# enet
+#
+################################################################################
+
+ENET_VERSION = 1.3.14
+ENET_SITE = http://enet.bespin.org/download
+ENET_LICENSE = MIT
+ENET_LICENSE_FILES = LICENSE
+
+ENET_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))