gst1-plugins-bad: fix webrtc option
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 08:11:54 +0000 (10:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Jul 2017 09:50:54 +0000 (11:50 +0200)
When the WebRTC plugin option was introduced in commit
ee267886bc090335dd94c97dca1c294addccc090 ("gst1-plugins-bad: enable
webrtc plugin"), it was incorrect added as "webrtc", while the actual
name of the plugin and corresponding configure option is "webrtcdsp".

This commit therefore fixes the .mk file to use the correct name. And
also, since we want to keep Buildroot option consistent with the name
of the GStreamer plugins, it renames the Config.in option as well, and
introduces the necessary Config.in.legacy handling.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 453c5eb8b8b8be5d105ab1d8c5496ee8ca4b823b..ddb0ffe80d6276867e1099501e81236234dc589d 100644 (file)
@@ -145,6 +145,16 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2017.08"
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
+       bool "gst1-plugins-bad webrtc renamed to webrtcdsp"
+       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
+       select BR2_LEGACY
+       help
+         The WebRTC plugin in GStreamer 1.x has always been named
+         webrtcdsp, but was wrongly introduced in Buildroot under the
+         name webrtc. Therefore, we have renamed the option to match
+         the actual name of the GStreamer plugin.
+
 config BR2_STRIP_none
        bool "Strip command 'none' has been removed"
        select BR2_LEGACY
index 17cc22be21a2277322717b04a6ff2c393f6560fd..fd3ca938c4fcfdcab5e43098eadf18118bf3e37a 100644 (file)
@@ -698,8 +698,8 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBP
        help
          Webp image format plugin
 
-config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
-       bool "webrtc"
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP
+       bool "webrtcdsp"
        # All depends from webrtc-audio-processing
        depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
        depends on BR2_INSTALL_LIBSTDCPP
@@ -710,7 +710,7 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC
        help
          WebRTC echo-cancellation, gain control and noise suppression
 
-comment "webrtc needs a toolchain w/ C++, NPTL, gcc >= 4.8"
+comment "webrtcdsp needs a toolchain w/ C++, NPTL, gcc >= 4.8"
        depends on BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING_ARCH_SUPPORTS
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS_NPTL \
                || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
index ffc9ab4934212eda2e26d03e888027e5621a3485..46dd14ccb7b471119b6dfe38c7e119ed5db2d401 100644 (file)
@@ -813,11 +813,11 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-webp
 endif
 
-ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTC),y)
-GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtc
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WEBRTCDSP),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-webrtcdsp
 GST1_PLUGINS_BAD_DEPENDENCIES += webrtc-audio-processing
 else
-GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtc
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-webrtcdsp
 endif
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_X265),y)