gpsd: proper usage of prefix and DESTDIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 22:01:55 +0000 (00:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Jul 2012 16:25:42 +0000 (18:25 +0200)
prefix should always be /usr, and destdir must be passed as DESTDIR,
and in the environment, not as a scons argument. Finally, we pass the
sysroot= argument to scons so that it doesn't add -L/usr/lib
parameters when compiling.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gpsd/gpsd.mk

index c5270bd2ba70544fb3166a9dc0f78a6b1d8a1e8e..e96d9797909ae19cdb6d6e2393d75bbb1d4f6f40 100644 (file)
@@ -17,8 +17,9 @@ GPSD_SCONS_ENV = $(TARGET_CONFIGURE_OPTS)
 
 GPSD_SCONS_OPTS = \
        arch=$(ARCH)\
-       prefix=$(TARGET_DIR)/usr\
+       prefix=/usr\
        chrpath=no\
+       sysroot=$(STAGING_DIR)\
        strip=no
 
 ifeq ($(BR2_PACKAGE_NCURSES),y)
@@ -207,9 +208,9 @@ endef
 define GPSD_INSTALL_TARGET_CMDS
        (cd $(@D); \
                $(GPSD_SCONS_ENV) \
+               DESTDIR=$(TARGET_DIR) \
                $(SCONS) \
                $(GPSD_SCONS_OPTS) \
-               destdir=$(TARGET_DIR) \
                install)
        if [ ! -f $(TARGET_DIR)/etc/init.d/S50gpsd ]; then \
                $(INSTALL) -m 0755 -D package/gpsd/S50gpsd $(TARGET_DIR)/etc/init.d/S50gpsd; \
@@ -220,10 +221,9 @@ endef
 define GPSD_INSTALL_STAGING_CMDS
        (cd $(@D); \
                $(GPSD_SCONS_ENV) \
+               DESTDIR=$(STAGING_DIR) \
                $(SCONS) \
                $(GPSD_SCONS_OPTS) \
-               destdir=$(STAGING_DIR) \
-               includedir="$(STAGING_DIR)/usr/include" \
                install)
 endef