systemd: enable required kernel features.
authoreric.le.bihan.dev@free.fr <eric.le.bihan.dev@free.fr>
Mon, 24 Feb 2014 09:25:42 +0000 (10:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 25 Feb 2014 20:28:05 +0000 (21:28 +0100)
When systemd is chosen as init system, the required kernel features are
enabled.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk
package/systemd/Config.in

index d7f51b3ec8ebbce59e583ca9e3bf8b5f12a12297..f948e6c55295ef191b1538f5e62c9b729086b173 100644 (file)
@@ -195,7 +195,11 @@ define LINUX_CONFIGURE_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_FUNCTION_TRACER,$(@D)/.config))
        $(if $(BR2_PACKAGE_SYSTEMD),
                $(call KCONFIG_ENABLE_OPT,CONFIG_CGROUPS,$(@D)/.config)
-               $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config))
+               $(call KCONFIG_ENABLE_OPT,CONFIG_INOTIFY_USER,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_FHANDLE,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_AUTOFS4_FS,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_TMPFS_POSIX_ACL,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_TMPFS_POSIX_XATTR,$(@D)/.config))
        $(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
                $(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
        yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig
index eacc23cc6e115026124f7011d049d5e043506a5e..4f180a11f076b25dd5315d6cda5dc7748cd023f5 100644 (file)
@@ -26,8 +26,20 @@ config BR2_PACKAGE_SYSTEMD
          elaborate transactional dependency-based service control logic.
          It can work as a drop-in replacement for sysvinit.
 
-         Systemd requires a Linux kernel >= 3.0, with inotify, devtmpfs,
-         tmpfs vfs and tmpfs POSIX ACL enabled.
+         Systemd requires a Linux kernel >= 3.0 with the following options
+         enabled:
+
+         - CONFIG_CGROUPS
+         - CONFIG_INOTIFY_USER
+         - CONFIG_FHANDLE
+         - CONFIG_AUTOFS4_FS
+         - CONFIG_TMPFS_POSIX_ACL
+         - CONFIG_TMPFS_XATTR
+
+         These options will be automatically enabled by Buildroot if
+         it is responsible for building the kernel. Otherwise, if you
+         are building your kernel outside of Buildroot, make sure
+         these options are enabled.
 
          Systemd also provides udev, the userspace device daemon.