package/matchbox: make matchbox-lib a real package
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:19 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 20:55:48 +0000 (22:55 +0200)
Currently, the matchbox package is using weird, legacy constructs to
build its different parts.

Notably, it adds matchbox-lib to the list of packages to build, even
though it is not a real package since it does not have a Kconfig entry.

Fix that:
  - add a Kconfig entry for matchbox-lib
  - select it from the top-level matchbox package

Note that matchbox-common already depends on matchbox-lib.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/Config.in
package/matchbox/matchbox-lib/Config.in [new file with mode: 0644]
package/matchbox/matchbox.mk

index 7867ae38815d417c098ff7e92a69f93d5adb775e..70cc168ba0553195fb2950cfd31d5b18d8f12a20 100644 (file)
@@ -7,6 +7,7 @@ config BR2_PACKAGE_MATCHBOX
        select BR2_PACKAGE_XLIB_LIBXEXT
        select BR2_PACKAGE_XLIB_LIBXDAMAGE
        select BR2_PACKAGE_XLIB_LIBXCURSOR
+       select BR2_PACKAGE_MATCHBOX_LIB
        help
          Matchbox is an Open Source base environment for the X Window
          System running on non-desktop embedded platforms such as
@@ -17,6 +18,8 @@ config BR2_PACKAGE_MATCHBOX
 
 if BR2_PACKAGE_MATCHBOX
 
+source "package/matchbox/matchbox-lib/Config.in"
+
 config BR2_PACKAGE_MATCHBOX_PANEL
        bool "Matchbox Panel"
        help
diff --git a/package/matchbox/matchbox-lib/Config.in b/package/matchbox/matchbox-lib/Config.in
new file mode 100644 (file)
index 0000000..480e6fe
--- /dev/null
@@ -0,0 +1,2 @@
+config BR2_PACKAGE_MATCHBOX_LIB
+       bool
index fe1a7db59c0b875d96e0a0a98c65fa117525269a..e367df2f932459de92b014c055bcb34064568690 100644 (file)
@@ -1,4 +1,4 @@
 ifeq ($(BR2_PACKAGE_MATCHBOX),y)
 include $(sort $(wildcard package/matchbox/*/*.mk))
-PACKAGES += matchbox-lib matchbox-wm
+PACKAGES += matchbox-wm
 endif