package/gtest: fix host build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 1 Aug 2021 08:36:41 +0000 (10:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Aug 2021 09:37:03 +0000 (11:37 +0200)
Commit 9dfbbbb4105c47602da048c9bb9499fb8862e768 wrongly removed
dependency on host-python3 or host-python resulting in the following
build failure:

cp -rp /tmp/instance-2/output-1/build/host-gtest-1.11.0/googlemock/scripts/generator/cpp /tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages
cp: cannot create directory '/tmp/instance-2/output-1/per-package/host-gtest/host/lib/python2.7/site-packages': No such file or directory

Fixes:
 - http://autobuild.buildroot.org/results/a1d2e100a65d7c1c39c20bdd5bf687a804c94305

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gtest/gtest.mk

index 474d1273125ea81463d0c0a175ba54669be92439..6447954e36bb2a9176d03248a733888e7bb6a0ee 100644 (file)
@@ -21,8 +21,10 @@ HOST_GTEST_LICENSE = Apache-2.0
 HOST_GTEST_LICENSE_FILES = googlemock/scripts/generator/LICENSE
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
 HOST_GTEST_PYTHON_VERSION = $(PYTHON3_VERSION_MAJOR)
+HOST_GTEST_DEPENDENCIES += host-python3
 else
 HOST_GTEST_PYTHON_VERSION = $(PYTHON_VERSION_MAJOR)
+HOST_GTEST_DEPENDENCIES += host-python
 endif
 
 HOST_GTEST_GMOCK_PYTHONPATH = \