Fix it so we once again build the target root_fs
authorEric Andersen <andersen@codepoet.org>
Sat, 9 Oct 2004 04:34:21 +0000 (04:34 -0000)
committerEric Andersen <andersen@codepoet.org>
Sat, 9 Oct 2004 04:34:21 +0000 (04:34 -0000)
Config.in
Makefile
target/Config.in
target/cramfs/Config.in
target/ext2/Config.in [new file with mode: 0644]
target/ext2/Makefile.in [new file with mode: 0644]
target/jffs2/Config.in [new file with mode: 0644]
target/jffs2/Makefile.in [new file with mode: 0644]

index be95fbbe5250c3c3fb01ca9c0d79776e06f8cd60..076596223b959912367f5bf0f3f93b9f4d587e36 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -67,4 +67,5 @@ source "toolchain/Config.in"
 
 source "package/Config.in"
 
+source "target/Config.in"
 
index 90443f0947be0a2e3a6c41ac9fef5a372aa77aee..8eb91bac7abfb7c45c7ff3db6dc3bcddcea38e3b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -76,6 +76,7 @@ world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
 
 include toolchain/*/*.mk
 include package/*/*.mk
+include target/*/*.mk
 
 #############################################################
 #
index dbc631725a37754a440005402ffe425934a03215..cd67a718f5a8408505844528ab7112ced5321b1b 100644 (file)
@@ -3,6 +3,9 @@
 menu "Target Options"
 
 source "target/cramfs/Config.in"
+source "target/ext2/Config.in"
+source "target/jffs2/Config.in"
+source "target/squashfs/Config.in"
 
 endmenu
 
index 2ba1cdece85b954d15b3608e2733bf09c68815ef..c9b1fb9f1c1ca7d523da932f312b62db92c2de7a 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_TARGET_ROOTFS_CRAMFS
-       bool "Build a cramfs root filesystem for the target device"
+       bool "cramfs root filesystem for the target device"
        default n
        help
          Build a cramfs root filesystem
diff --git a/target/ext2/Config.in b/target/ext2/Config.in
new file mode 100644 (file)
index 0000000..7e137ae
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_EXT2
+       bool "ext2 root filesystem for the target device"
+       default y
+       help
+         Build an ext2 root filesystem
+
diff --git a/target/ext2/Makefile.in b/target/ext2/Makefile.in
new file mode 100644 (file)
index 0000000..9904077
--- /dev/null
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2)),y)
+TARGETS+=ext2root
+endif
diff --git a/target/jffs2/Config.in b/target/jffs2/Config.in
new file mode 100644 (file)
index 0000000..0d79dd1
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_JFFS2
+       bool "jffs2 root filesystem for the target device"
+       default n
+       help
+         Build a jffs2 root filesystem
+
diff --git a/target/jffs2/Makefile.in b/target/jffs2/Makefile.in
new file mode 100644 (file)
index 0000000..31452eb
--- /dev/null
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+TARGETS+=jffs2root
+endif