Commonalize the definition of TOOLCHAIN_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 28 Apr 2010 21:40:52 +0000 (23:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 22:00:05 +0000 (00:00 +0200)
The definition of TOOLCHAIN_DIR is the same regardless of whether
external or internal toolchains are used. Moreover, move its
definition together with all the other *_DIR definitions.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile
package/Makefile.in

index 54dd4f18545405a1d834108ad43465be95ec1307..271db9c59620cb36ee7e2bebaa7b7421c716292f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -267,6 +267,7 @@ STAMP_DIR:=$(BASE_DIR)/stamps
 
 BINARIES_DIR:=$(BASE_DIR)/images
 TARGET_DIR:=$(BASE_DIR)/target
+TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
 
 BR2_DEPENDS_DIR=$(BUILD_DIR)/buildroot-config
 
index 3dfc712da1522f713bec72ce770e3b264ba6a18d..396187d3be6e8d8b167e7527c5e58d48d1d5c935 100644 (file)
@@ -105,7 +105,6 @@ ROOTFS_SUFFIX:=-$(BR2_ROOTFS_SUFFIX)
 endif
 
 ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
-TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
 
 # Quotes are needed for spaces et al in path components.
 TARGET_PATH="$(TOOLCHAIN_DIR)/bin:$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:$(PATH)"
@@ -116,7 +115,6 @@ KERNEL_CROSS=$(TARGET_CROSS)
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
 TOOLCHAIN_EXTERNAL_PREFIX:=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
 TOOLCHAIN_EXTERNAL_PATH:=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PATH))
-TOOLCHAIN_DIR=$(BASE_DIR)/toolchain
 TARGET_PATH="$(HOST_DIR)/bin:$(HOST_DIR)/usr/bin:$(HOST_DIR)/usr/sbin/:$(TOOLCHAIN_DIR)/bin:$(TOOLCHAIN_EXTERNAL_PATH)/bin:$(PATH)"
 REAL_GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)
 GNU_TARGET_NAME=$(TOOLCHAIN_EXTERNAL_PREFIX)