package/python-semantic-version: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Thu, 11 Feb 2021 05:12:50 +0000 (22:12 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Mar 2021 21:34:57 +0000 (22:34 +0100)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/python-semantic-version/python-semantic-version.hash [new file with mode: 0644]
package/python-semantic-version/python-semantic-version.mk [new file with mode: 0644]

diff --git a/package/python-semantic-version/python-semantic-version.hash b/package/python-semantic-version/python-semantic-version.hash
new file mode 100644 (file)
index 0000000..692905e
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/semantic-version/json
+md5  76d7364def7ee487b6153d40b13de904  semantic_version-2.8.5.tar.gz
+sha256  d2cb2de0558762934679b9a104e82eca7af448c9f4974d1f3eeccff651df8a54  semantic_version-2.8.5.tar.gz
+# Locally computed sha256 checksums
+sha256  a85e7ef2fbc670d26781ed6844cd31a7e8ada65d21328f75a0b02402faae37ea  LICENSE
diff --git a/package/python-semantic-version/python-semantic-version.mk b/package/python-semantic-version/python-semantic-version.mk
new file mode 100644 (file)
index 0000000..2352690
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-semantic-version
+#
+################################################################################
+
+PYTHON_SEMANTIC_VERSION_VERSION = 2.8.5
+PYTHON_SEMANTIC_VERSION_SOURCE = semantic_version-$(PYTHON_SEMANTIC_VERSION_VERSION).tar.gz
+PYTHON_SEMANTIC_VERSION_SITE = https://files.pythonhosted.org/packages/d4/52/3be868c7ed1f408cb822bc92ce17ffe4e97d11c42caafce0589f05844dd0
+PYTHON_SEMANTIC_VERSION_SETUP_TYPE = setuptools
+PYTHON_SEMANTIC_VERSION_LICENSE = BSD-2-Clause
+PYTHON_SEMANTIC_VERSION_LICENSE_FILES = LICENSE
+
+$(eval $(host-python-package))