python-pyhamcrest: new package
authorAsaf Kahlon <asafka7@gmail.com>
Wed, 26 Sep 2018 15:35:03 +0000 (18:35 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 4 Oct 2018 11:59:58 +0000 (13:59 +0200)
Hamcrest framework for matcher objects.

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-pyhamcrest/Config.in [new file with mode: 0644]
package/python-pyhamcrest/python-pyhamcrest.hash [new file with mode: 0644]
package/python-pyhamcrest/python-pyhamcrest.mk [new file with mode: 0644]

index b2718b82c42b640aec2d902ae1709811096cd623..74bc703a6b5e791b5086d8b78b193651121e4081 100644 (file)
@@ -208,6 +208,7 @@ F:  package/python-paramiko/
 F:     package/python-passlib/
 F:     package/python-pyasn1/
 F:     package/python-pyasn1-modules/
+F:     package/python-pyhamcrest/
 F:     package/python-pyroute2/
 F:     package/python-pytz/
 F:     package/python-reentry/
index 13b24f18158073b8c0e973e4e710e3cb21dd5520..17627ad840f7ee75d6795a971ba21bf3f6963488 100644 (file)
@@ -929,6 +929,7 @@ menu "External python modules"
        source "package/python-pyftpdlib/Config.in"
        source "package/python-pygame/Config.in"
        source "package/python-pygments/Config.in"
+       source "package/python-pyhamcrest/Config.in"
        source "package/python-pyicu/Config.in"
        source "package/python-pyinotify/Config.in"
        source "package/python-pylibftdi/Config.in"
diff --git a/package/python-pyhamcrest/Config.in b/package/python-pyhamcrest/Config.in
new file mode 100644 (file)
index 0000000..c2a4dc0
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_PYHAMCREST
+       bool "python-pyhamcrest"
+       select BR2_PACKAGE_PYTHON_SETUPTOOLS # runtime
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       help
+         Hamcrest framework for matcher objects.
+
+         https://github.com/hamcrest/PyHamcrest
diff --git a/package/python-pyhamcrest/python-pyhamcrest.hash b/package/python-pyhamcrest/python-pyhamcrest.hash
new file mode 100644 (file)
index 0000000..0c1660e
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/pyhamcrest/json
+md5    8b833a3fa30197455df79424f30c8c3f  PyHamcrest-1.9.0.tar.gz
+sha256 8ffaa0a53da57e89de14ced7185ac746227a8894dbd5a3c718bf05ddbd1d56cd  PyHamcrest-1.9.0.tar.gz
+# Locally computed sha256 checksums
+sha256 ec76c04449607010d061b1e29c9d20a5ffae74db9d04670ae82538ccfe68b941  LICENSE.txt
diff --git a/package/python-pyhamcrest/python-pyhamcrest.mk b/package/python-pyhamcrest/python-pyhamcrest.mk
new file mode 100644 (file)
index 0000000..244aa8c
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-pyhamcrest
+#
+################################################################################
+
+PYTHON_PYHAMCREST_VERSION = 1.9.0
+PYTHON_PYHAMCREST_SOURCE = PyHamcrest-$(PYTHON_PYHAMCREST_VERSION).tar.gz
+PYTHON_PYHAMCREST_SITE = https://files.pythonhosted.org/packages/a4/89/a469aad9256aedfbb47a29ec2b2eeb855d9f24a7a4c2ff28bd8d1042ef02
+PYTHON_PYHAMCREST_SETUP_TYPE = setuptools
+PYTHON_PYHAMCREST_LICENSE = BSD-3-Clause
+PYTHON_PYHAMCREST_LICENSE_FILES = LICENSE.txt
+
+$(eval $(python-package))