package/linux-firmware: make install logic macro accept a destination parameter
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 15 Feb 2021 16:05:55 +0000 (17:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 23 Feb 2021 12:49:13 +0000 (13:49 +0100)
So it can be reused for also installing into the images directory.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linux-firmware/linux-firmware.mk

index 9bc59435ef2ee927bcf4878f684293909e8f3902..8defedd309fd457fc9693ae20c1bed1e5db552d0 100644 (file)
@@ -674,10 +674,10 @@ endif
 # sure we canonicalize the pointed-to file, to cover the symlinks of the form
 # a/foo -> ../b/foo  where a/ (the directory where to put the symlink) does
 # not yet exist.
-define LINUX_FIRMWARE_INSTALL_TARGET_CMDS
-       mkdir -p $(TARGET_DIR)/lib/firmware
-       $(TAR) xf $(@D)/br-firmware.tar -C $(TARGET_DIR)/lib/firmware/
-       cd $(TARGET_DIR)/lib/firmware/ ; \
+define LINUX_FIRMWARE_INSTALL_FW
+       mkdir -p $(1)
+       $(TAR) xf $(@D)/br-firmware.tar -C $(1)
+       cd $(1) ; \
        sed -r -e '/^Link: (.+) -> (.+)$$/!d; s//\1 \2/' $(@D)/WHENCE | \
        while read f d; do \
                if test -f $$(readlink -m $$(dirname $$f)/$$d); then \
@@ -687,4 +687,8 @@ define LINUX_FIRMWARE_INSTALL_TARGET_CMDS
        done
 endef
 
+define LINUX_FIRMWARE_INSTALL_TARGET_CMDS
+       $(call LINUX_FIRMWARE_INSTALL_FW, $(TARGET_DIR)/lib/firmware)
+endef
+
 $(eval $(generic-package))