package/mpv: disable vaapi with DRI driver
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 14 Sep 2021 16:15:11 +0000 (18:15 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 22 Sep 2021 21:03:38 +0000 (23:03 +0200)
Build of vaapi with BR2_PACKAGE_MESA3D_DRI_DRIVER is broken since commit
17a7abbafee9bf4a971e00da7870ae439910e47e because vaapi can only be
enabled with x11, wayland or egl-drm
(https://github.com/mpv-player/mpv/blob/ec0006bfa1aaf608a7141929f2871c89ac7a15d6/wscript#L632):

'deps': 'libdl && (x11 || wayland || egl-drm)',

As a result, despite what is being displayed in the autobuilder log
message, the build failure is not related to X11 but to the fact that
we try to enable vaapi through a DRI driver but without egl.

Fixes:
 - http://autobuild.buildroot.org/results/5ae706e94eb6e5a3aa69368f81c5d12e608b1a5a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/mpv/Config.in
package/mpv/mpv.mk

index 51c9799de833e1bdde1d36243dbb3c0c7cb6f9e9..81b1e24b5f0d21aa7c01e99c827ac8b1d166ba8a 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_MPV_SUPPORTS_VAAPI
        bool
-       default y if BR2_PACKAGE_LIBDRM && BR2_PACKAGE_MESA3D_GBM
+       default y if BR2_PACKAGE_LIBDRM && BR2_PACKAGE_MESA3D_OPENGL_EGL
        default y if BR2_PACKAGE_WAYLAND
        default y if BR2_PACKAGE_XORG7
 
index a71a4b31143434c2091e45700f8ca18f0b1ab470..ff77f248e56fa64ee98491899a04c910e2cb2614 100644 (file)
@@ -184,7 +184,7 @@ endif
 ifeq ($(BR2_PACKAGE_LIBVA)$(BR2_PACKAGE_MPV_SUPPORTS_VAAPI),yy)
 MPV_CONF_OPTS += --enable-vaapi
 MPV_DEPENDENCIES += libva
-ifeq ($(BR2_PACKAGE_LIBDRM)$(BR2_PACKAGE_MESA3D_GBM),yy)
+ifeq ($(BR2_PACKAGE_LIBDRM)$(BR2_PACKAGE_MESA3D_OPENGL_EGL),yy)
 MPV_CONF_OPTS += --enable-vaapi-drm
 else
 MPV_CONF_OPTS += --disable-vaapi-drm