barebox: prepare for auxiliarry build
authorPieter Smith <pieter@boesman.nl>
Sun, 24 Apr 2016 21:15:23 +0000 (23:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 May 2016 12:27:45 +0000 (14:27 +0200)
No functional changes. In preparation for the auxiliary barebox build,
boot/barebox is split into two parts:
1. boot/barebox:
   - The source and patch specification which are to be shared between the
     barebox and barebox-aux packages.
   - The barebox-package function and build logic.
2. boot/barebox/barebox:
   - The package configuration, fragments, barebox env, etc.
   - The actual barebox package make instantiation.

Signed-off-by: Pieter Smith <pieter@boesman.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/barebox/Config.in
boot/barebox/barebox.mk
boot/barebox/barebox/Config.in [new file with mode: 0644]
boot/barebox/barebox/barebox.hash [new symlink]
boot/barebox/barebox/barebox.mk [new file with mode: 0644]

index 07295861590030d127069988d2f78467e672e259..e25b14bd600f40337f0d201fc1abb76b1084e4cc 100644 (file)
@@ -64,71 +64,6 @@ config BR2_TARGET_BAREBOX_CUSTOM_GIT_VERSION
 
 endif
 
-
-choice
-       prompt "Barebox configuration"
-       default BR2_TARGET_BAREBOX_USE_DEFCONFIG
-
-config BR2_TARGET_BAREBOX_USE_DEFCONFIG
-       bool "Using a defconfig"
-
-config BR2_TARGET_BAREBOX_USE_CUSTOM_CONFIG
-       bool "Using a custom config file"
-
-endchoice
-
-config BR2_TARGET_BAREBOX_BOARD_DEFCONFIG
-       string "board defconfig"
-       depends on BR2_TARGET_BAREBOX_USE_DEFCONFIG
-       help
-         Name of the board for which Barebox should be built, without
-         the _defconfig suffix.
-
-
-config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
-       string "Configuration file path"
-       depends on BR2_TARGET_BAREBOX_USE_CUSTOM_CONFIG
-       help
-         Path to the barebox configuration file
-
-config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
-       string "Additional configuration fragment files"
-       help
-         A space-separated list of configuration fragment files,
-         that will be merged to the main Barebox configuration file.
-
-config BR2_TARGET_BAREBOX_IMAGE_FILE
-       string "Image filename"
-       help
-         Name of the generated barebox image, which will be copied to
-         the images directory.
-
-         If left empty, defaults to:
-         - barebox.bin for barebox versions older than 2012.10.
-         - barebox-flash-image for later versions.
-
-config BR2_TARGET_BAREBOX_BAREBOXENV
-       bool "bareboxenv tool in target"
-       help
-         Install bareboxenv tool in target.
-
-config BR2_TARGET_BAREBOX_CUSTOM_ENV
-       bool "Generate an environment image"
-       help
-         Generate a custom environment image. This environment will
-         contain the variables and scripts to be used at boot by
-         barebox.
-
-config BR2_TARGET_BAREBOX_CUSTOM_ENV_PATH
-       string "Environment path"
-       depends on BR2_TARGET_BAREBOX_CUSTOM_ENV
-       help
-         Path to the directory containing the custom barebox
-         environment. Depending on your setup, it will probably be
-         based on either the content of the defaultenv or
-         defaultenv-2 directories in the barebox source code, plus
-         the additions needed. The output will be an image in the
-         barebox devfs format, stored in the images directory, with
-         the same name as the directory name given here.
+source boot/barebox/barebox/Config.in
 
 endif
index a5b1b1ec99c35250a39afde3dd2a45b1c3b8e736..8b83bf2bbb698369210b64ca55a56bc4d47a1729 100644 (file)
@@ -142,5 +142,4 @@ endef
 
 barebox-package=$(call inner-barebox-package,$(call UPPERCASE,$(pkgname)))
 
-# instantiate this barebox package
-$(eval $(barebox-package))
+include boot/barebox/barebox/barebox.mk
diff --git a/boot/barebox/barebox/Config.in b/boot/barebox/barebox/Config.in
new file mode 100644 (file)
index 0000000..bf13ea5
--- /dev/null
@@ -0,0 +1,65 @@
+choice
+       prompt "Barebox configuration"
+       default BR2_TARGET_BAREBOX_USE_DEFCONFIG
+
+config BR2_TARGET_BAREBOX_USE_DEFCONFIG
+       bool "Using a defconfig"
+
+config BR2_TARGET_BAREBOX_USE_CUSTOM_CONFIG
+       bool "Using a custom config file"
+
+endchoice
+
+config BR2_TARGET_BAREBOX_BOARD_DEFCONFIG
+       string "board defconfig"
+       depends on BR2_TARGET_BAREBOX_USE_DEFCONFIG
+       help
+         Name of the board for which Barebox should be built, without
+         the _defconfig suffix.
+
+
+config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
+       string "Configuration file path"
+       depends on BR2_TARGET_BAREBOX_USE_CUSTOM_CONFIG
+       help
+         Path to the barebox configuration file
+
+config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
+       string "Additional configuration fragment files"
+       help
+         A space-separated list of configuration fragment files,
+         that will be merged to the main Barebox configuration file.
+
+config BR2_TARGET_BAREBOX_IMAGE_FILE
+       string "Image filename"
+       help
+         Name of the generated barebox image, which will be copied to
+         the images directory.
+
+         If left empty, defaults to:
+         - barebox.bin for barebox versions older than 2012.10.
+         - barebox-flash-image for later versions.
+
+config BR2_TARGET_BAREBOX_BAREBOXENV
+       bool "bareboxenv tool in target"
+       help
+         Install bareboxenv tool in target.
+
+config BR2_TARGET_BAREBOX_CUSTOM_ENV
+       bool "Generate an environment image"
+       help
+         Generate a custom environment image. This environment will
+         contain the variables and scripts to be used at boot by
+         barebox.
+
+config BR2_TARGET_BAREBOX_CUSTOM_ENV_PATH
+       string "Environment path"
+       depends on BR2_TARGET_BAREBOX_CUSTOM_ENV
+       help
+         Path to the directory containing the custom barebox
+         environment. Depending on your setup, it will probably be
+         based on either the content of the defaultenv or
+         defaultenv-2 directories in the barebox source code, plus
+         the additions needed. The output will be an image in the
+         barebox devfs format, stored in the images directory, with
+         the same name as the directory name given here.
diff --git a/boot/barebox/barebox/barebox.hash b/boot/barebox/barebox/barebox.hash
new file mode 120000 (symlink)
index 0000000..b6462b8
--- /dev/null
@@ -0,0 +1 @@
+../barebox.hash
\ No newline at end of file
diff --git a/boot/barebox/barebox/barebox.mk b/boot/barebox/barebox/barebox.mk
new file mode 100644 (file)
index 0000000..6a5a80d
--- /dev/null
@@ -0,0 +1,8 @@
+################################################################################
+#
+# barebox
+#
+################################################################################
+
+# Instantiate the barebox package
+$(eval $(barebox-package))