Remove references to module-init-tools
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 Sep 2013 21:01:01 +0000 (23:01 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 Sep 2013 21:01:34 +0000 (23:01 +0200)
Now that it is replaced by kmod.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
docs/manual/faq-troubleshooting.txt
package/kmod/kmod.mk

index f91a8ef50481eb8fb63f11aa35c5343a4c31c2a8..4e0612b8d7cd908d53c4f44ef83099b28b58d3ff 100644 (file)
@@ -27,21 +27,6 @@ configuration+, and modify +Port to run a getty (login prompt) on+ and
 +/etc/inittab+ file of the generated system so that a shell starts on
 the correct serial port.
 
-[[faq-module-init-tool-build-failure]]
-module-init-tools fails to build with 'cannot find -lc'
--------------------------------------------------------
-
-If the build of +module-init-tools+ for the host fails with:
-
-------------------------
-/usr/bin/ld: cannot find -lc
-------------------------
-
-then probably you are running a Fedora (or similar) distribution, and
-you should install the +glibc-static+ package. This is because the
-+module-init-tools+ build process wants to link statically against the
-C library.
-
 [[faq-no-compiler-on-target]]
 Why is there no compiler on the target?
 ---------------------------------------
index 649415fe215224daf2e05fab4c4ddd5f7890fde6..9ac773103fe01522c9d5d66e9594b06f40fa36c7 100644 (file)
@@ -42,10 +42,8 @@ ifeq ($(BR2_PACKAGE_KMOD_TOOLS),y)
 KMOD_LICENSE += GPLv2+
 KMOD_LICENSE_FILES += COPYING
 
-# take precedence over busybox / module-init-tools implementations
-KMOD_DEPENDENCIES += \
-       $(if $(BR2_PACKAGE_BUSYBOX),busybox) \
-       $(if $(BR2_PACKAGE_MODULE_INIT_TOOLS),module-init-tools)
+# take precedence over busybox implementation
+KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_BUSYBOX),busybox)
 
 define KMOD_INSTALL_TOOLS
        for i in depmod insmod lsmod modinfo modprobe rmmod; do \