package/chrony: add option for debug logging
authorRobert Hancock <hancock@sedsystems.ca>
Wed, 29 May 2019 23:18:06 +0000 (17:18 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 27 Oct 2019 20:51:02 +0000 (21:51 +0100)
Add a BR2_PACKAGE_CHRONY_DEBUG_LOGGING config option to allow enabling
compiled-in support for debug logging in Chrony.

Signed-off-by: Robert Hancock <hancock@sedsystems.ca>
[Arnout: don't enable by default]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/chrony/Config.in
package/chrony/chrony.mk

index 05d6fc1a25cf050368a88a3218a1e2631e2f0569..158dc2053077c10ecf2d4a9abce354444255610b 100644 (file)
@@ -6,3 +6,11 @@ config BR2_PACKAGE_CHRONY
          accuracy of the system clock.
 
          http://chrony.tuxfamily.org/
+
+config BR2_PACKAGE_CHRONY_DEBUG_LOGGING
+       bool "enable debug logging support"
+       depends on BR2_PACKAGE_CHRONY
+       help
+         Enable support for debug logging output from Chrony when
+         enabled at runtime. If disabled, code for debug logging will
+         not be compiled in.
index 4a740d5067e348fbd0ce2813b10912f0908af915..f6dcb117942782aa9e66096c018502b6e3268562 100644 (file)
@@ -13,7 +13,8 @@ CHRONY_CONF_OPTS = \
        --host-system=Linux \
        --host-machine=$(BR2_ARCH) \
        --prefix=/usr \
-       --without-tomcrypt
+       --without-tomcrypt \
+       $(if $(BR2_PACKAGE_CHRONY_DEBUG_LOGGING),--enable-debug,--disable-debug)
 
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
 CHRONY_DEPENDENCIES += libcap