package/links: enable building graphics mode with only fb driver
authorUrja Rannikko <urjaman@gmail.com>
Tue, 27 Apr 2021 09:13:25 +0000 (12:13 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 18 May 2021 19:41:47 +0000 (21:41 +0200)
The "fb" framebuffer driver needs GPM (mouse support) to compile,
but not DirectFB or Xorg.

The .mk file already has an optional dependency on GPM, so it doesn't
need to be added there.

Also added a Kconfig comment for easier discovery of the GPM
requirement.

Signed-off-by: Urja Rannikko <urjaman@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/links/Config.in

index 713f53da4e4839e6b57b68b0017d05e1433c80af..cc2389c9f16770a6a7a4939b503c3cc6fd092fcc 100644 (file)
@@ -10,11 +10,15 @@ if BR2_PACKAGE_LINKS
 
 config BR2_PACKAGE_LINKS_GRAPHICS
        bool "use graphics"
-       depends on BR2_PACKAGE_DIRECTFB || BR2_PACKAGE_XORG7
+       depends on BR2_PACKAGE_GPM || BR2_PACKAGE_DIRECTFB || BR2_PACKAGE_XORG7
        select BR2_PACKAGE_XLIB_LIBXT if BR2_PACKAGE_XORG7
        select BR2_PACKAGE_LIBPNG
        help
-         Enable graphics output for DirectFB or X11.
+         Enable graphics output for framebuffer, DirectFB or X11.
+         Framebuffer output requires GPM (console mouse).
          Otherwise links will be text-mode only.
 
+comment "links graphics needs GPM, DirectFB or X11"
+       depends on !BR2_PACKAGE_GPM && !BR2_PACKAGE_DIRECTFB && !BR2_PACKAGE_XORG7
+
 endif