micropython: Invert fallback detection logic
authorChris Packham <judge.packham@gmail.com>
Wed, 23 Sep 2015 23:43:49 +0000 (11:43 +1200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 24 Sep 2015 07:51:20 +0000 (09:51 +0200)
Rather than specifying architectures that do not have explicit support
in micropython invert the logic and set MICROPY_GCREGS_SETJMP=1 if the
architecture does not have explicit support. MIPS is listed as being
supported but this support consists of automatically defining
MICROPY_GCREGS_SETJMP 1 based on __mips__ being defined.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/micropython/micropython.mk

index 7ae88a05e4ede2e2b61368ce8b0a87677b2b24c6..1358864cc90a1cfe3738495e90db2d9f28fb1680 100644 (file)
@@ -15,7 +15,7 @@ MICROPYTHON_PATCH = \
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.
-ifeq ($(BR2_powerpc)$(BR2_sh)$(BR2_xtensa),y)
+ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
 MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
 endif